crwdns2894164:0crwdne2894164:0

Trackpad stops working after 15 minutes

Just replaced my trackpad with one from Ifixit. Now the trackpad works great for about the first 15-20 minutes, then it stops responding completely. After another 5 minutes or so, the cursor starts moving all over the screen and clicking by itself without me moving it. Any thoughts? Might I have damaged the trackpad cable? I was thinking if I did, it wouldn’t work at all, but it works fine for the first 15-20 minutes.

Did a little more troubleshooting. Seems that it happens anytime I click near the left side of the track pad in order to click an icon or to click and drag an icon..

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

crwdns2893810:0crwdne2893810:0

Carefully loosen the screws holding the battery, did that help?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

Loosened the screws a little and then all the way. It helped a little bit. Pointer still doesn’t always respond. Clicker works but cursor movement is very erratic and sometimes not at all.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@brodeurman1 - OK that implies the battery has swelled up pressing on the trackpad and/or the trackpad cable.

Take the battery fully out. Press the power button to fully discharge the logic board now plug in the MagSafe the system should spontaneously startup. Does the trackpad work better now?

If not you'll need a new trackpad and cable follow this guide MacBook Air 11" Late 2010 Trackpad Replacement

MacBook Air 11" (Late 2010) Trackpad

MacBook Air 11" (Late 2010) Trackpad Cable

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Did all that. Took battery out, pressed power button, then connected the power cord. Computer didn’t start up on it’s own. I pressed power button to start up. With battery out of the computer and on external power, there is no change. Moving around the pointer is still jumpy and sometimes doesn’t move at all. This is already a new trackpad that I put in a couple of days ago. I’m going to assume that I damaged the trackpad cable. I have one on order. Hopefully that will be the fix. Guess it could be a defective trackpad from iFixit also?

Thanks for the info so far! I’ll post my results once I get the new cable.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Put new cable in today. Same issue. Then I took the battery out and powered up with the MagSafe only. Worked great. This battery was replaced about 2 years ago, so I put the old battery back in and it is working fine. The other battery must have been really swelled. I'm concluding that I must have damaged the original cable when I swapped out the trackpad. For all I know, I may not have needed a trackpad in the first place.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

brodeurman1 crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 1

crwdns2894768:07crwdne2894768:0 6

crwdns2894768:030crwdne2894768:0 29

crwdns2894770:0crwdne2894770:0 465