{A1706 / EMC 3071}—Released in June 2017, this 13" Macbook Pro features Kaby Lake processors up to 3.5 GHz Core i7 with Turbo Boost up to 4.0 GHz.

crwdns2886949:0257crwdne2886949:0 crwdns2858137:0crwdne2858137:0

MacBook Pro 2017 not coming up after not being used for sometime


I have left my MacBook Pro for more than a month now without using it. Now when I try to power it up, it won’t come up. Any advice on what to do or what the issue might be?


Here is the screenshot after installing CoconutBattery. Does it seem that there is any issue with my battery?

Block Image

Block Image

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0

Can you tell us what is your exact model 13" or 15"?


It's a 13-inch Macbook Pro


Well, the good news the battery is still OK! But you are running your system hard! You have quite a few cycles for such a young system. You should get into the habit of not letting the battery run down so far before charging. When you run down below 30% you will likely push a cycle which will add up to the point you'll need a new battery.

I'm wondering if one of your ports is damaged which is why you had a problem charging the system before. I think it would make sense getting the power meter to check if you have a bad port. As it turns out the port assembly is easy to replace.





Sadly, the newer 2016 onward MacBook Pro’s don’t truly turn off when you think they are. They just go into a sleep mode. So if your system was not fully charged its likely to have fully drained the battery to the point its can’t recover being unplugged for so long.

You’ll need a means to see whats happening within the USB-C connection to your power adapter like this one Satechi USB-C Power Meter. That way to you tell of the power adapter and its cable are working correctly or if you’ll need to replace the battery.

Reference If your Mac doesn't turn on or start up


crwdns2889612:0crwdne2889612:0 1


Thanks a lot, @danj. So I tried everything on the reference link but unfortunately, none worked for me.

So, I left it plugged in since when I made this post whenever I had power and I tried to put it on every day since then but today surprisingly, it just worked!


@dongido - Lets check that battery install this gem of an app CoconutBattery take a snapshot of the apps window and post it here for us to see Adding images to an existing question Do one with the power adapter disconnected and then one with it connected.


@danj updated the question with the screenshot from CoconutBattery


Thanks a lot for the advice @danj , will look to it. Yeah, the ports are working well.




gideon onwuka crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 89