Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

crwdns2886949:01148crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Can a board be water damaged without showing it?

I have an iPhone 3G that refuses to connect to the computer. I've taken it apart and replaced the dock connector, as that showed the water damage sticker, but that did not fix the problem. The rest of the board *appears* to be fine, but I'm not sure now. Additionally, the headphone jack is still white (as opposed to red).

Any idea as to what could be wrong?

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0


Does the iPhone work well? Have you tried with more cables? with any other computer? Maybe it can't give 2A of power to the USB port, try disconnecting all and connecting only the iPhone. Let me know...


crwdns2889612:0crwdne2889612:0 0

It's pretty well DOA. The previous owner had it jailbroken, and it was then reset, which typically means that it has to be plugged into the computer for a restore. It worked decently before that, though the cell radio might not have worked.

I've tried it with... hmm, about 5 different cables and 8 different computers. It never even pops up, even when put in DFU mode.


crwdns2889612:0crwdne2889612:0 0

Hi Josh / All,

I have one with the same error. I can get it to turn on and get it into DFU mode - but it doesnt appear to 'ping' the PC?

by that I mean generally speaking you hear the iPhone connect to the computer and start processing the recovery drivers - this one doesn't.

I've switched everything possible. basically put the logic board into different handsets with different batteries/dock connectors etc - had no luck at all.

I've just finished the process of cleaning the PCB with PCB & Flux cleaner - again no luck.

The previous guy I think had tried to replace the back cover and ended up using superglue. I know this as there was some on the board. After cleaning etc I thought that might do the trick - bold textJosh if you havent tried that I would recommend doing it!!

I had one previously that seemed to navigate the menu's by itself - 1 night resting after a spray with the PCB spray fixed it.

shame this one wont :(

please help someone!! I wish I knew someone with a MAC I could try it with - they work better with them dont they?



crwdns2889612:0crwdne2889612:0 0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 1,703