Will not charge replaced battery and IO board

I have a 11” MacBook Air.

It was just on my desk for maybe about a year without using. Decided to pull it out one day and charge it. It did not charge. No lights at all. I bought a replacement battery thinking it’s the battery. Was able to finally turn it on and then I tried to charge it. Still not light. I went to Apple store and they said they cannot service it because i have a third party battery. But he said it’s mostly likly the I/O board. Went here to purchase a replacement I/O board. And still will not charge. SMC and PRAM were both reset. I just used the last juice in the replacement battery. I don’t know where to proceed from here . Any suggestions?

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0


What was the mag-safe adapter light doing?

Apple would not help you with it anyway as it is over six years old. Reminds me of an old military joke about officers. Do you know what that little white speck on the top of a pile if chicken sh*t is? That chicken sh*t too, So is Apple.


Nothing, except of a VERY dim green light. I tried 2 chargers, both are known to be in working order




Dim MagSafe LED is a sign the charging/power logic on the main logic board is having problems.

The cause can be caused by a liquid spill damaging the TPS 51980 Buck Converter which is on the top side of the logic board (hidden side). Marked in Black here

Block Image


crwdns2889612:0crwdne2889612:0 0


Alan crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 117