crwdns2894164:0crwdne2894164:0

Dot (.) and comma (,) not functioning on the keyboard. How to fix it?

All other keys except dot (.) and comma(,) are not functioning. I thought by formatting the laptop will solve the issue but I am stuck as I am unable to use (.) to put in my apple ID. I have erased it completely and was trying to reinstall the OSX 10.7 lion but don't know what to do?

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 1

1 Comment:

Have you tried connecting an external USB keyboard?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

Have you tried using an external keyboard?

If it works in the external keyboard, the mechanism below the keys are most likely defect, which is fixed by replacing the entire keyboard. This is quite a time extensive and difficult repair. But if done carefully, it is doable.

What might be another solution you can try since the keys aren’t working: you can take the keycap of the keyboard, by sticking something like a guitar pick under the key (check google/ifixit to see how to). Cleaning it and trying to press the mechanism without the key, will show you if the keyboard underneath the keys is defect or not.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

milind crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 2

crwdns2894768:07crwdne2894768:0 10

crwdns2894768:030crwdne2894768:0 46

crwdns2894770:0crwdne2894770:0 1,521