The 2013 revamp of the desktop Mac series known as the Mac Pro.

crwdns2886949:0102crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Mac Pro wont power on, red LED?


First, sorry for the hiatus. I've been out of the business for a while. But I'm back!

Apple couldn't tell me anything. They offered me to pay a flat $500 fee, and they would replace anything that needed to be replaced untill it worked…

I ended up just selling it for parts…

So I have a Apple Mac Pro "Quad Core" 3.7 (Late 2013) that wont power on.

I do not know the history of the machine.

I plugged it in and got nothing, no beeps. no fan spinning, no response.

I do all the normal procedures, swapped ram, tried different SSD, reset SMC, tried different power cable and outlet. None of that worked.

I took the case off and found a bright red LED shinning.

Block Image

So I started searching the internet, thinking that there MUST be some information about this red LED.... NOTHING!!!

So I proceeded to take the whole thing apart, took it down to bare bones to make sure everything was connected properly and to see if I could find any corrosion from any liquid damage or such.

While I was at it I re applied thermal paste on both the CPU and GPU.

Nothing appeared to be out of place, no damage to the board, all connections were secure.

I put it back together, powered it on, and still nothing, just the red LED...


Please, if you have any idea what could be wrong, any suggestions, or any explanation about this red LED I would LOVE to hear it.

I'm totally baffled by this one...

Thanks in advanced,


crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 1



I tried different types of RAM, Low voltage RAM, and ECC RAM... No luck.

Based on someones suggestion I tried booting without one of the two graphics cards plugged in, no luck there.

I am at a loss.

Is thing just not gonna boot for me?


Same issue. In my case, the red light was coming from the bottom of the unit, the logic board. I replaced the logic board and was back in business. Turns out, it had been dropped. Dent on the bottom and the riser stand-off screws holding the logic board in place were broken.




Hi! Did you solve it? I have the same problem. Best regards Petter


crwdns2889612:0crwdne2889612:0 0


Same problem. Plz, help in a advice.



Any luck?

Was just handed a mac pro with exact same problem. This was after upgrading CPU.. only a red led on psu board lights when power cord plugged in and another red LED on the bottom (round) logic board. pressing power gives no life of any kind.


crwdns2889612:0crwdne2889612:0 0


Taylor Struna crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 10

crwdns2894768:07crwdne2894768:0 23

crwdns2894768:030crwdne2894768:0 85

crwdns2894770:0crwdne2894770:0 2,465