crwdns2894164:0crwdne2894164:0

Fourth generation iPhone. Repair is straightforward, but the front glass and LCD must be replaced as a unit. GSM / 8, 16, or 32 GB capacity / Model A1332 / Black and White.

crwdns2886949:02345crwdne2886949:0 crwdns2858137:0crwdne2858137:0
crwdns2893812:0crwdne2893812:0

After doing DIY repair on iPhone it will not turn on.

My husband repaired a problem with my iPhone 4. It created a second problem which he then fixed. Now I cannot get anything but the charging picture to show up and it is fully charged. It just will not turn on. Battery is good. This happened 10 minutes after fix, it was on then shut down and now nothing.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

It might help if you can tell us what was fixed. Have you tried a hard reset yet? Did you try to place it in DFU mode?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

what happens if you plug it in to the wall charger? if it powers on then I'd check you battery connection is securely on and that all the opening etc hasn't lifted the solder on the pins.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

he took it apart to fix the speaker (I dropped it in paint but because there was a mophie on it everything was fine but the speaker had paint in it. The warranty is void from the paint. Once the speaker was replaced reopened to reconnect the antennae (or whatever that is) now it does nothing. Even after being plugged in all day it shows the low battery charging icon and NOTHING else

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Sounds like the dock connector is either loose or faulty. Or the battery connector itself. Maybe in fixing the speaker ( was it the one in the dock??) he damaged the dock?? Or if you replaced that part you received a faulty part?? Try putting old part back in if that's the case.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:02crwdne2886779:0

Have him take a look at the battery connector to see if he accidentally lifted the pins off of the board itself, there are four pins and sometimes people will pry them off if they are in a rush or not extremely careful.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

also you might check the power/lock button there may have been an issue with the switch.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 775