It sounds like the SSD might indeed be either wiped or malfunctioning, especially since it's not showing up in Disk Utility or as an option for installing macOS. Based on the symptoms, here are a few additional steps you can take to either confirm SSD failure or troubleshoot further:
In recovery mode, you can open Terminal and use some commands to check if the system detects the SSD at all:
- Run this command to list all disks:
Copy code
diskutil list
- This will show all attached storage devices. If your internal SSD doesn’t appear, it’s likely either completely wiped or failed.
- If the SSD does appear but isn’t formatted correctly, you could try reformatting it using Terminal:
Copy code
diskutil eraseDisk JHFS+ MacHD disk0
- Replace
disk0
with the actual disk identifier if different.
If the SSD is visible but greyed out in Disk Utility, try the following steps:
- Select "View" -> "Show All Devices" in Disk Utility to see if the SSD shows up.
- If it does, select it, then click "Erase" and try formatting it as APFS (the default macOS format) or Mac OS Extended (Journaled).
If it's still not showing, then it's likely that the SSD is either corrupted beyond normal repair or physically damaged.
Although you've already done this, it might be worth resetting NVRAM/PRAM and SMC once more, just to make sure nothing was missed:
- NVRAM/PRAM reset: Shut down the Mac. Turn it on and immediately press and hold Option + Command + P + R for about 20 seconds until it restarts.
- SMC reset: Shut down the Mac. Hold Shift + Control + Option + Power for about 10 seconds, then release all keys and power it on normally.
If the SSD isn’t being detected in recovery mode, it could indicate a deeper issue. Boot into Internet Recovery (Option + Command + R) and check if you can install macOS onto the SSD there.
- If no internal disk appears for installation, then the SSD may be beyond saving.
Since you have access to an external drive, try booting macOS from an external disk or USB installer (if you haven't already). If this works, it confirms the internal SSD isn't being detected. You could also try cloning a working macOS installation to the internal SSD (if detected by cloning tools).
If Apple Diagnostics reported no issues, it might mean that the SSD controller is still functioning, but the storage module itself could be at fault. You can run the diagnostics once more to double-check if anything new is flagged.
If none of these steps work, it might be time to visit an Apple Store or authorized repair center. Given the symptoms and the fact that macOS isn’t detecting the SSD, it could point to SSD failure or a more severe motherboard issue.
Unfortunately, if the SSD has failed and it's soldered to the motherboard (as is the case in some models), a repair may involve replacing the entire logic board.
Edit: 15/9/2024
If you're still not able to detect the internal SSD on your MacBook despite trying the usual recovery methods, the issue could be more serious, possibly a hardware failure. Since none of the above steps worked, I'll outline additional troubleshooting steps to explore before considering hardware replacement or professional repair.
Even if diskutil list
and system_profiler
didn't show anything, we can try another low-level command using Terminal in Recovery Mode to check if the SSD is recognized at the hardware level:
- Open Terminal from Utilities in Recovery Mode.
- Run the following command:
css
- Copy code
ioreg -l | grep -i IONVMeController
- This command searches for the NVMe controller, which manages SSDs in newer MacBooks. If you get a result, it means the system sees the SSD hardware, but it may have partitioning or other issues. If nothing shows up, it's likely a hardware failure.
If you see the SSD via ioreg
or similar commands but it doesn't appear in Disk Utility, you can try manually erasing and reformatting the SSD via Terminal. Here's how:
- Open Terminal from Recovery Mode.
- Use
diskutil list
again to see if the disk appears (even if unformatted or corrupted). - Identify the disk identifier for the SSD (e.g.,
/dev/disk0
). - If it's listed, you can try to reformat the disk manually:
bash
- Copy code
diskutil eraseDisk JHFS+ MacintoshHD /dev/disk0
- Replace
/dev/disk0
with the actual identifier of the SSD. This command erases the drive and formats it as HFS+, which is what macOS uses.
Sometimes, firmware issues with the NVMe SSDs in MacBooks can cause them to disappear from Disk Utility. In such cases, a macOS reinstall from Internet Recovery might help.
- Boot into Internet Recovery again by holding Option + Command + R.
- Reinstall macOS over the network and see if the SSD is detected during the install process. If it’s detected, this could fix a firmware-related issue.
Since you’ve successfully booted from an external drive, you can use that environment to check for internal SSD issues with more advanced utilities:
- Boot from External Drive (macOS installed on USB or external SSD).
- Once booted, open Disk Utility again to check for the internal drive.
- Use third-party software like DriveDx or TechTool Pro to perform a detailed hardware scan of the SSD, if it’s detected at all.
Booting into Safe Mode might help bypass some issues with macOS that are causing the SSD not to be recognized:
- With your external drive connected, restart your Mac.
- Immediately hold Shift until you see the Apple logo. This will boot your Mac into Safe Mode.
- Check Disk Utility again and see if the internal SSD is available.
You can try reinstalling macOS on an external drive, and if the SSD becomes available later, clone the system back to the internal SSD:
- Install macOS on an external USB or SSD (if not done already).
- Use software like Carbon Copy Cloner to try to clone the external installation onto the internal SSD (if it becomes visible again).
In rare cases, corrupted or outdated system firmware can cause issues detecting the internal drive. You can reset the firmware with a DFU mode restore (if you're comfortable doing so), which requires another Mac to restore the firmware via Apple Configurator 2.
If you’re comfortable and skilled with hardware, you can try inspecting the SSD connection. Since you're using a 2017 Retina MacBook Pro, the SSD might be soldered onto the motherboard, but you can still:
- Turn off the Mac and open the back cover using the right tools.
- Carefully inspect the SSD area for any signs of loose connections, debris, or damaged components around the SSD and motherboard.
- Inspect SSD Flex Cable (if it uses one) to ensure it’s securely connected and not damaged.
Sometimes internal damage (e.g., from liquids or impacts) can cause drive failures. While you have the MacBook open:
- Look for corrosion around the SSD and other components.
- Check for any burned or discolored areas that might indicate hardware damage.
If none of the above steps work, the SSD may have failed, or there could be a logic board issue. Since the SSD is likely soldered on your model, replacing it yourself is impractical. At this point, taking the MacBook to an Apple Store or an authorized repair center is the best option.
If the internal SSD is dead and repair isn’t feasible, you can continue using the MacBook by permanently booting from an external SSD. Modern USB-C or Thunderbolt 3 SSDs are fast enough to serve as primary storage for most tasks. Just ensure it’s configured properly:
- Install macOS on the external SSD.
- Use Disk Utility to set the external drive as the default boot disk.