crwdns2894164:0crwdne2894164:0

The Acer Nitro 5 AN515-53-55G9 is a laptop targeted towards budget gamers. It boasts 256 GB of storage, Nvidia GeForce Graphics and an Intel i5 quad-core processor at a more affordable price than most gaming laptops.

crwdns2886949:057crwdne2886949:0 crwdns2858137:0crwdne2858137:0

8GB usb stick not being detected

Why isn't an 8GB USB stick being detected in bios? The USB stick is not faulty and the USB port is working.

And there is no way to get the device past the acer screen so I am trying to get windows to do a clean install from a usb but I can't because of the problem above ^

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2917036:09crwdne2917036:0

Hey NS, first how old is the USB, what color is the flat piece on the USB, and have you tried the USB on a different device?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

If you are trying to flash the bios then look in your manual for the bios flash USB.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@nytryder26 I don't know how old the usb is and it does work on a different device and its a black PNY 8GB

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@nstrains Do you have an OS on the Acer?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@nytryder26 windows 10, but it has some problems so I need a clean install

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:04crwdne2893776:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:02crwdne2886779:0

crwdns2893814:0crwdne2893814:0

Hi @nstrains

Plug in the USB flashdrive, start the laptop and get into BIOS (press F2)

When in BIOS check that under the Main tab, that Fast Boot is disabled. (When fast boot is enabled the USB ports aren't checked on startup).

Also check under the Boot tab that Secure Boot is disabled.

You should see the USB flashdrive listed as a boot option.

Save the changes and exit BIOS and restart the laptop.

When the laptop restarts press F12 and then select the USB drive as the desired boot device.

Update (09/24/2022)

@nstrains

I doesn't help if you don't answer whether or not you've checked what I suggested above. If it still doesn't work then at least there are other things to try but unless you tell us we won't know!

Create a Win 10 recovery disc, either by downloading online or from any known working Win 10 PC.

In the host PC go to Control Panel > Recovery > Create a recovery disc and follow the prompts.

Doing either will create a bootable disc that you can install Win 10 from.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2917036:05crwdne2917036:0:

now it says bootx64.efi not found

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@nstrains

Well at least the laptop BIOS recognizes the USB now which it didn't before so now you have an install problem, which is different to what you first had.

Out of interest what was the problem regarding not seeing the USB?

Did you create a bootable Win 10 32-bit or 64-bit install file on the USB?

If it was a 32 bit then perhaps the UEFI BIOS of your laptop only recognizes 64 bit versions.

Check the USB and make sure that there is a bootx64.efi file in its correct directory.

It should show as ... \efi\boot\bootx64.efi.

If it is not on the USB at all you've got the wrong version

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I have a windows 7 x64 iso on the usb

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@nstrains

Win 7 is too long ago for me to remember exactly what to do so perhaps you may have to search online .

Why Win 7 anyway? It is far safer to have Win10 especially if you're online a lot

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

now it says there are no drivers installed

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Tips to fix-

#1) Restart Your Computer.

#2) Update Computer.

Tenorshare 4DDiG.

#3) Change USB Root Hub Settings.

#4) Update USB Driver.

#5) Check And Change Ports.

#6) Change USB Selective Suspended Settings.

#7) Format Your Drive.

Regards,

Rachel Gomez

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

NS Trains crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 3

crwdns2894768:07crwdne2894768:0 20

crwdns2894768:030crwdne2894768:0 79

crwdns2894770:0crwdne2894770:0 196