crwdns2894164:0crwdne2894164:0

2.2 GHz (Turbo Boost up to 3.4 GHz), 2.5 GHz (Turbo Boost up to 3.7 GHz), or 2.8 GHz (Turbo Boost up to 4.0 GHz) quad-core Intel Core i7 processor with 6 MB shared L3 cache.

crwdns2886949:0665crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Temperature sensor locations for 15" 2015 MacBook Pro

Hello. Just replaced thermal compound on 2015 macbook pro. Upon restart the fans slowly ramp up to full and the computer runs slow. Also diagnostics is saying SMC issue. with code PFM006. I'm trying to identify the temp sensors. are they the round spongy things to either side of the CPU and graphics chip?

Update (05/12/2022)

Hi Dan. I already own iStat Menu and can give you a screen shot from that. pretty sure it lists all my fans and temp sensors.

Block Image

Update (05/13/2022)

Ok, downloaded the trial version of TG Pro. Results look the same as iStat Pro. Looks like all temp sensors are reading valid results, but computer is running painfully slow, and fans running at full. Any suggestions appreciated. Thanks!

Block Image

I believe my logic board number is 820-3787. However I got this number by referencing the model number and EMC number. Without removing the logic board I am unable to find any number that is formatted 820-xxxx.

Other info that may or may not be relevant.

Mid 2015 retina Macbook Pro 2.5 GHz. 16 GB ram. 250 GB SSD.

Model A1398

EMC 2910

I can also give the serial number of the computer if that helps at all.

Thanks!

Block Image

Block Image

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

Lets get a better view of things, install this great app! TG Pro take a snapshot of the main screen making sure to capture all of the sensors and fans (you may need two snapshots) and post it here for is to see Adding images to an existing question

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Some versions are not as good as TG Pro missing some sensors. The free version is all we need to review. Give it a try.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Keir Briscoe PFM006 - There may be an issue with the System Management Controller (SMC). Apparently it can also be popping up with a failed trackpad cable/connector. What board is this? The voltage sensor is a simple resistor from which usually comes from a 3.3v line straight to the SMC. So if the resistor is good and traces are good then the SMC-Circuitry will be having issues. Let us know the exact logicboard number 820-xxxxx and post some good pictures of your board with your question. That way we can hopefully point things out

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

oldturkey03. have added a photo of the logic board on my original post.

Thanks for the help on this. I super appreciate all the feedback and education I am getting here!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Keir Briscoe the 820-3787 would be for a 2013 to Mid 2014. The attached picture shows your board? If so then that board is a 820-00163 which will make it a 2015 MBP. Bottom left on the logic board shows it ;-)

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:04crwdne2893776:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:03crwdne2886779:0

crwdns2893810:0crwdne2893810:0

So, The Apple Genius did his thing and found absolutely nothing wrong with the SMC according to their in house testing. He did find an error with the SSD, or the SSD socket. However he also noted that it seems to be working fine even though it shows an error. When the computer was being tested the fans did not spin up to full speed either.

Now that I have it at home its again giving an SMC error when I run diagnostics, and the fans are running up. So, No real answers for all my efforts.

The Genius concurred that the thermal paste replacement I did wouldn't cause this. So it may be an intermittent problem and the seller knew this, hence the fairly good price I got it for.

I'm going to buy a logic board. It would be required for either of the above errors. It seems whatever is going on that should fix it.

Thanks for everyone's feedback and help on this issue

Keir

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1
crwdns2892346:0crwdne2892346:0
crwdns2893814:0crwdne2893814:0

Well, your issue is not a thermal sensor issue as all of the sensors are woking!

It looks like you have one of the current/voltage sensors failing which is why your systems fan is ramped up and the CPU's clocking is reduced (CPU Safe Mode).

I would inspect your cable connections and make sure you haven't damaged the connectors both cable and logic board.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

Can I ask where you see a current/voltage sensor failing from the images I uploaded? cleaning the fans and replacing thermal paste did not require disconnecting any wires. So no connections have been changed.

I have also double checked the logic board with a visual inspection and there is no indication of a loose connection or broken wire.

Do you know a specific test I can do to identify which sensor might be bad? Thanks again!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@Keir Briscoe - Reviewing the schematics is how I know its a current/voltage sensor. At this point its a deep process the isolate out which sensor is firing off and the reason could be a few possibilities.

One action was when you cleaned and applied new thermal paste there are a few SMT components on the chip carrier which could have been damaged and/or the paste is shorting across as you applied too much.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

@Keir Briscoe can you post another picture just a nice clean close up of the area I've marked (red)? Remove the covers or flip them up (blue) so we can see the components under it. Something odd there....or just my old eyes. Just out of curiosity why did you change teh thermal paste? Anything transpired to make you do it?

Block Image

Update (05/18/2022)

Okay so the temperature sensors are pretty much on the other side of your board. Since you did not move it at all etc. it is unlikely that those are at fault but you asked for it :-)

GPU PROXIMITY/GPU DIE/LEFT FIN STACK/RIGHT FIN STACK Reference designator U5850

DDR3 PROXIMITY/CPU PROXIMITY/PCH PROXIMITY/AIRFLOW PROXIMITY Reference designator U5870

X87 PROXIMITY Reference designator U5823

TBT DIE Reference designator XW5820

Block Image

Block Image

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

oldturkey03. Did the photo I posted help at all? I replaced the paste because when I bought it the original owner said it had never been done. The laptop is 7 years old and in my experience paste that old is going to be less effective. And indeed the old paste was crumbly and dry.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Keir Briscoe sorry I missed that new post altogether. Yes, the image clarified that it was my old eyes. the fuse for the trackpad looks okay as well :-)

I do agree with the thermal paste and your error is an odd one since it literally came out of the blue. Any chance you can the diagnostics on this to start While I check the schematics and see if anything strange shows up.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Running Apple diagnostics returns the result;

"There may be an issue with the System Management Controller (SMC). Reference Code: PFM006"

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Keir Briscoe that is such a generic error. you did try a SMC reset correct? Choose Apple menu > Shut Down and wait for your Mac to shut down.

Press Shift-Control-Option on the left side of the built-in keyboard, then press the power button at the same time. Hold these keys and the power button for 10 seconds.

Release all keys.

Press the power button again to turn it on

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@oldturkey03 Yes I have tried SMC reset and PRAM reset multiple times. I am taking the day to go to the Apple store in Vancouver tomorrow. I hope that a Genius is able to give me an idea of what I will need to buy. I'll report back with what I find out, if for nothing else, to bring this thread to some kind of resolution. Thanks!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893774:01crwdne2893774:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Keir Briscoe crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 7

crwdns2894768:07crwdne2894768:0 21

crwdns2894768:030crwdne2894768:0 90

crwdns2894770:0crwdne2894770:0 348