crwdns2894164:0crwdne2894164:0

The Razer Blade Stealth are a line of premium Ultrabooks by Razer. The latest model is the Razer Blade Stealth (2019)

crwdns2886949:047crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Replacement batteries keep dying.

I bought a replacement battery for my Razer Blade Stealth 13.3” (2017). After installing the battery, it worked fine for a while. Then I left it to charge fully and kept it plugged in while the laptop was powered off. When I came back, the battery wasn’t working at all. I also bought a second replacement battery and installed it and the same thing happened; it worked fine, sustained charge and was charging normally. I left it plugged in and then when I tried powering the laptop on it wouldnt do anything. I used a multimeter to check and saw 0V across the terminals of both batteries. With the dead battery connected and the laptop being plugged in for power, the battery icon on the taskbar shows the battery as normal and plugged in and says “(96% available, plugged in)”, but as soon as you remove the charger the laptop switches off and doesnt power on again (on battery). I’m not sure why this happened since laptops have protection from overcharging. The original battery that came with my laptop works fine, no problems with charging (so it’s not a fault in the charger), the reason I wanted to replace it was because its capacity had decreased and wouldnt power the laptop for longer than 20 mins.

I apologize for the long description.

Any information on why this might have happened would be highly appreciated.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

I am having the same problem. Like, exactly the same with my 2017 Razer Stealth. My original battery is bloated, but still works while the replacement is not working. In addition, I got a replacement for my replacement and I made sure to turn on the laptop right after installing the new battery and it worked without being plugged in. After charging for a few hours the battery would no longer provide power if unplugged. I am using the original USB-C charger that came with my laptop.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Well, I just had the EXACT same thing happen to me. My old battery wasn’t holding charge for more than a few minutes off power so I ordered a new one off ifixit and replaced the older battery which was beginning to bloat. Installed and powered it on, left it charged until at capacity (only reached 96%) and left it for a number of hours. As soon as the power plug is removed, it falls over. I uninstalled the drivers and rechecked the connection. The battery report shows the battery change and lack of ability to draw off the battery….but again, is showing that it is 96% charged. It was at <5% when I installed it originally. Battery is brand new from ifixit and at a bit of a loss.

Soooo anyone have any bright ideas?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I'm facing exact same issue. I'm at a computer store and I've checked upto 5 replacements from different vendors. What I think is that these batteries have stayed in the store for so long that their cells are now dead. What do we do then? Are we to maybe half charge the battery for multiple times (ensuring it doesn't go near 90%)? And how long do we have to do this before the battery cells adjust. I'm so frustrated right now because I had to cover many miles to solve this battery problem. Can someone try to see if this solves the problem?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:02crwdne2886779:0

crwdns2893814:0crwdne2893814:0

Hi @maazo_o,

To eliminate the possibility of faulty batteries, create a Win 10 battery report to check the status of the battery.

Compare the Design capacity value versus the Full Charge capacity value. With a new battery they should be the same or close to it.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

Hi! Thanks for the reply. Yes, I did that, and it shows both values to be very close to each other (although Full Charge Capacity is somehow higher than Design Capacity).

**

Design Capacity: 50,820 mWh

Full Charge Capacity: 52,864 mWh

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

In the battery reports, both batteries show 96% and 50,774 mWh of Capacity remaining, but they dont charge any further nor do they power the laptop at all when the charger is disconnected.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@maazo_o

I've also noticed that with a Win 10 battery report that the full charge capacity exceeds the design capacity when the batteries are new but I don't know why this is but in the laptops that I've checked it hasn't affected anything.

Regarding your laptop if I read your question correctly initially it charged OK and worked on the new battery but subsequently it showed that it was charging but would not start or run on the battery only and when you measured the battery it showed 0V, is this about right?

Was the 0V with the charger connected or just the battery only?

Try uninstalling the Microsoft ACPI Compliant Control Method Battery in Device Manager and then restarting the laptop and letting Windows "find" it and reinstall it again.

To get to Device manager in Win 10 press the Win key + x key (both together) and then click on the Device manager link.

When in Device Manager click on the > symbol next to the Batteries category to expand the list and then right click on Microsoft ACPI Compliant Control Method Battery > Uninstall and follow the prompts.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@jayeff

I uninstalled the ACPI driver and let the laptop reinstall it on startup itself. Didn't work.

Regarding your question; I probed the terminals of the battery with a multimeter and it read 0V. When I do the same for my old/original battery, it reads ~12.3V when fully charged. I don't know how everything is configured but I'm assuming that the problem is in the power delivery lines of the battery itself since the laptop detects the battery as normal and shows capacity info etc.. For some reason they both got damaged, I just can't understand how or why.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@maazo_o

0V indicates that the battery is totally flat.

After reinstalling the ACPI driver etc does the laptop still say that the battery is 96%? If it now shows something else (hopefully < 5%) it may take a while for it to start recharging again. Give it a while e.g. 2-4 hours and check if the charge % rises at all. To speed things up, do not turn on the laptop, simply leave it on charge only.

Probably too hard to read the battery terminals when the charger is connected to see whether it is charging or not i suppose?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:02crwdne2893776:0

crwdns2892346:0crwdne2892346:0

From what I can tell this sounds like you are using a power supply which is ABOVE the rated voltage of your blade I suggest double checking the voltage input of your blade and the output of your power supply, overcharge protection protects you from well, overcharging, it does not mean there is overvoltage protection.

If this happens to be the case I recommend purchasing a new charger from RAZER’ s webstore here: https://www.razer.com/gaming-pc-accessor... it is currently out of stock but when its back in I suggest getting one if the power supply was the problem.

If the original battery worked then maybe the battery specs of the ones you ordered were for a different model and did not function properly, that or you just have insanely bad luck with batteries, batteries dying during shipping isn’t all that uncommon due to heat

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

Thanks for the reply. The battery I ordered is compatible with my model (I checked with the product number of the laptop) and the charger I am using is exactly the one you linked to. The laptop doesnt register it as a dead battery or no battery connected. Also creates a battery-report which shows Design Capacity ad Full Charge Capacity to be very close to each other (although Full Charge Capacity is higher than Design Capacity for some reason). The reason why I dont think it was because of heat or damage during shipping is because both worked when initially installed, and died when were left connected to the charger for a long time when the laptop was in sleep mode.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I'm Sorry that I wasn't able to help solve your problem :/

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@rektronik

Not a problem. I appreciate your response ! :)

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Maaz Bashir crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 1

crwdns2894768:07crwdne2894768:0 19

crwdns2894768:030crwdne2894768:0 53

crwdns2894770:0crwdne2894770:0 778