crwdns2894164:0crwdne2894164:0

Repair and troubleshooting guides for the Asus Republic of Games Strix 15.6" gaming laptop with model number GL503VM-B17N13.

crwdns2886949:09crwdne2886949:0 crwdns2858137:0crwdne2858137:0

No power, no led, no POST. Replaced Motherboard, same issue.

I have a ROG STRIX GL530VM that overheated. The machine would not boot up at all but it would show a charging LED. I tried everything and couldn’t get it to respond. So, I ordered a ‘known good’ replacement and swapped out the mainboard. However, now it’s worse as I do not even get the orange charging LED.


Thinking it might be something with power delivery I replaced the DC charging input, the AC adapter and main battery as well as a brand new CMOS battery. Still get the same, no response.


I pulled the motherboard again and re-checked the LED connector and it appears to be seated properly with no visible issues with the ribbon cable connecting.

I re-pasted the processors with Thermal Grizzly paste and ensured it is properly seated. (even if it wasn’t I would at least get fans spinning up).


All repairs are done by myself; A+ certified IT professional of 25 years. On a computer workbench while wearing an ESD strap.

Any thoughts on what else might be the issue? I reached out on the ‘new’ motherboard since it is under warranty but I feel like maybe I missed something unique to these units that I am not familiar with.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Tried everything . . . How are we supposed to know what you tried?

If replacement board does not work at all perhaps the problem is the display, the hard drive, the wireless card, etc.

Disconnect everything and if that still doesn't work disconnect the display screen and try an external monitor.

Could be there is nothing wrong with the original system board.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

Hi

Had the same woes with a Lenovo T460. Charging light was on, power button would light up when pressed, but still nothing was displayed and no error beeps.

In the end it turned out to be a faulty memory module.

Once I’ve replaced the memory module, the laptop came back to life.

So, it’s worth checking this too.

Cheers!

Bogdan

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Jerod Singley crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 1

crwdns2894768:030crwdne2894768:0 7

crwdns2894770:0crwdne2894770:0 71