crwdns2894164:0crwdne2894164:0

Released September 16, 2016. Models A1661, A1784, and A1785. Available in 32, 128, or 256 GB configurations in Rose gold, gold, silver, black, jet black, and (Product)Red.

crwdns2886949:01268crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Prox, Ambient light sensor and mic not working

Hi everyone. I have an iPhone 7 Plus. I just changed the screen, in the process the front sensors and camera ribbon cable came apart. I thought no biggie, I’ll just replace the cable. As of right now, with the new cable the front camera works, but the proximity and ambient light sensors do not. The earpiece and microphones don’t work either.

Any suggestions on what to try next? Thanks.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

Check the pins on the ear speaker to make sure they’re not bent or missing. Also make sure the connector clicks into place. Usually when I have this issue it’s because I didn’t seat the connector all of the way. If that doesn’t fix it, order another flex assembly as they can sometimes have defects. If you don’t mind me asking, where did you buy the replacement from?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Hi Jesse. Thanks for the quick reply! I actually bought 2 flex cables because I know how weak they are, neither work. I even bought and tried a new earpiece just in case that was an issue.

I live in Canada and purchased the parts from a website esourceparts.ca. They have been very good for the most part.

Is it possible the damaged flex cable shorted something out? I wouldn’t think so because it was just separating at the solder joints. After reinstalling it on the new screen and testing it out once; only to find the sensors didn’t work, I pulled the phone apart and realized it had separated.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@Dmak did you disconnect the battery while you performed the repairs?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Yup! Always do.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@Dmak well then you might have a board level issue on your hands. But first try a restore if you can.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Dmak crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 2

crwdns2894770:0crwdne2894770:0 69