crwdns2894164:0crwdne2894164:0

crwdns2890822:0crwdne2890822:0

crwdns2890844:0crwdne2890844:0

crwdns2861143:0crwdne2861143:0

The smaller of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

crwdns2886949:0131crwdne2886949:0 crwdns2858137:0crwdne2858137:0

No green light on charger

When I received this MacBook it was working fine only on a charger and with the battery disconnected. When I connect the battery and a charger I get the green light on a charger for a few moments, then it turns to orange light but MacBook powers on just once, and after I turn it off it won’t start again.

I have tried with SMC reset but nothing happens, except green/orange light change on a charger.

This was happening before MacBook went dead. Now, there is no green light on a charger, with or without the battery connected.

I opened the MacBook and measured voltage on L7095 - with just a battery plugged in I get 3.42V. but when I connect just the charger I don’t get any voltage on L7095. With battery and charger connected I also get 0V.

What could be a problem, where to look?

Update: I tried plugging in the MacBook to a charger after a few hours and I did get the green light on a charger, but after a few seconds light started to dim until goes off completely.

crwdns2893852:0crwdne2893852:0 View the answer crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

crwdns2886779:03crwdne2886779:0

crwdns2893810:0crwdne2893810:0

Just to post an update and close this thread I will explain how I found what’s wrong with the motherboard…

The problem was with the bad solder on Zener diode D7012, and I found this by measuring the voltage on the capacitor C7012 - on pad 1 of the capacitor I was getting around 15V (voltage from the MagSafe) but on the pad 2 of the capacitor I was getting around 14V which is not good. The voltage on pad 2 of C7012 needs to be around 6.8V because of the Zener diode (GDZT2R6.8) that pulls down the voltage. This voltage drop is needed in order for Q7010 to open and send the same voltage on pin 1 (6.8V). Since I was not getting the right voltages I checked the diode under the microscope and found that one pad was not soldered correctly.

I also replaced the diode with another one, but since I didn’t have the MacBook donor board I used the diode from the iPhone 5S motherboard :) It is the same diode but the one from the iPhone board is rated at 6.2V instead of 6.8V, but anyway it works :) This diode is placed near the LCD connector on the iPhone board.

I hope this will help someone else to solve the problem.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0
crwdns2893814:0crwdne2893814:0

What is PPBUS_G3H with battery and without? If around 8.5V with battery and really low with magsafe check U7100 and Q7180 but probably Q7180 is bad.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 3

crwdns2893872:0crwdne2893872:0:

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I tested PPBUS_G3H on F7140 - with just the battery plugged in I get 7.04V, with just a MagSafe it's 0V, with battery and MagSafe it's 7.04V.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Here are some values with just a charger plugged in, if that can help:

R7185 - 15V one pin, 14.24V on 2nd

R7186 - 14V, 13.6V

R7180 - 5.5V

R7181 - 5.1V

R7121 and R7122 - 5.5V

R7151 and R7152 - 0V

R7110 and R7111 - 0V

Resistance on all resistors is OK.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@betrocker Current sensing resistors need to be checked in Ohms not diode. Compare readings with known good board. If you are not sure what the readings should be just go ahead and replace Q7180

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@imicrosoldering It's not in diode mode, it is voltage while the charger is plugged in. Resistance is OK on all resistors.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:03crwdne2893776:0

crwdns2892346:0crwdne2892346:0

If you haven’t already, try to power on the machine with a separate known-good charger connected. If this doesn’t work, you most likely have an issue with your battery, MagSafe board, or logic board. Try disconnecting the battery, connecting the charger, and pressing the power button. If the machine is able to power on with the battery disconnected and run off of charger power you probably have a bad battery. If you have a friend with a compatible model you can try installing their battery to see if it resolves the issue. If you aren’t able to get any signs of life with the battery disconnected, you can read the voltage on the MagSafe board with a multimeter to see if it’s passing the right voltage. If it’s not passing enough voltage you probably have a failed MagSafe board. If it’s passing too much voltage you probably have a short on your logic board.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Thanks for the reply, but I already tried all that and the problem is that I’m not getting green light on a charger.

Battery is new and the charger is known good since I’m using it for another macbook.

Like I said in my post, I get 3.42V on L7095 when battery is connected, but I don’t get voltage from a charger on L7095.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

betrocker crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 3

crwdns2894768:030crwdne2894768:0 46

crwdns2894770:0crwdne2894770:0 46