crwdns2894164:0crwdne2894164:0

Model A1225 / Early 2009 / 2.66, 2.93, or 3.06 GHz Core 2 Duo processor

crwdns2886949:0158crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Why doesn't my iMac boot up?

For a few weeks I have a beautiful iMac 24” 2.93Ghz.

It functions quite good, with one problem. When moving it and plugging it into another wall socket it has to sit there for a few hours before being able to boot up. This was the case for the last few weeks. Very weird, but bearable.

Since yesterday however, it doesn’t but up, not even after a couple of hours in a socket or after changing the power cable.

  • What could be the problem here? Something with the power supply I guess?
  • What can I do to further diagnose the problem?
crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2886779:02crwdne2886779:0

crwdns2893814:0crwdne2893814:0

When you disconnect the AC cord you are loosing the vampire power the system requires to hold the PRAM settings, so the small Li-Ion button battery is used. What happens here is the battery is worn-out from age and lack of use! So the system looses its settings. But, when you plug in your system again and let it sit for awhile there is enough power leaking to the battery to give it a bit of a charge (not designed to charge though) so the settings become available after awhile, this only lasts a few times before the battery can’t be charged anymore.

Time to replace the battery! Follow this guide to get to it iMac Intel 24" EMC 2267 Front Bezel Replacement. You’ll find the silver disk button battery in the bottom right corner near the speaker - 3 volts BR2032.

The other possibility is the Power supplies capacitors have failed do to Capacitor Plague that will require a new power supply iMac Intel 24" EMC 2267 2.66, 2.93 & 3.06 GHz Power Supply

crwdns2886500:0iMac Intel 24" EMC 2267 2.66, 2.93 & 3.06 GHz Power Supplycrwdne2886500:0

crwdns2893848:0crwdne2893848:0

iMac Intel 24" EMC 2267 2.66, 2.93 & 3.06 GHz Power Supply

$139.99

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2917036:08crwdne2917036:0:

Thanks for this good suggestion! I will try that.

Even though, I just started the diagnosis myself and removed the front bezel. Then I saw the power LED lit up, and tried to boot, and it worked again. Strange behaviour.

Nonetheless, I will replace that battery I guess.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Is it ok to replace the BR2032 with the CR2032, since the output is the same, only the chemistry is different?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Yes, That works too!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

The replacement battery doesn't seem to fix it. This morning the iMac worked again. A few hours ago I 'transplanted' it again to a different socket, and now I'm again waiting for the power LED to come on. I'm curious how long this will take again.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@milvo - Time to check the power supply caps

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:03crwdne2893776:0

crwdns2892346:0crwdne2892346:0

This is what they look like. They don’t look damaged to me? How do they look to you?

Block Image

Block Image

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Niels de Vos crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 71