crwdns2894164:0crwdne2894164:0

crwdns2890822:0crwdne2890822:0

crwdns2890844:0crwdne2890844:0

crwdns2861143:0crwdne2861143:0

Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

crwdns2886949:01612crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Installing Windows 10 on new ssd

I recently added a new SSD in the old optical drive slot and use the old HD as additional storage. I had no success with moving the two OS over to the SSD so, I chose to do a fresh install. I have successfully gotten a fresh install of OSx on the SSD and everything boots fine. However, I am now trying to install windows OS on the SSD using bootcamp. I get the partition and everything set up fine but, when I get to the windows installer I am getting the error message “Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu.”

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

How are you installing Windows?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

With bootcamp. I made the bootable USB. Go through making the partition in bootcamp assistant, then letting the computer restart and boot to the USB.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

@matt1992 - I'm suspecting the format of the USB drive is not correct. It needs to be a exFAT or Fat32.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:02crwdne2886779:0

crwdns2893810:0crwdne2893810:0

This is a known issue with drives in the optical slot. Put the SSD in the normal hard drive slot, and your extra HDD in the optical drive slot and it should work.

If it still doesn’t work, you should put your old optical drive back in and install windows to the SSD slot via a DVD rather than the USB installer.

Update: I was confusing two different issues. Windows won’t install with two drives installed in the system at all. If you only have the SSD installed, the Windows installation should work fine.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

Thanks. I found similar information about the optical drive. I'm working on doing that now. I'll update when I find out if it works or not.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Where did you get that Idea?

The SATA bays are the same! The Boot is controlled within the systems EFI setting it does not depend on any bay ID.

You're thinking PATA & SCSI which used the cable or drive ID.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Sorry, I wasn't thinking straight. The problem isn't that it's in the optical bay, the problem is that Windows won't install on the machine with two hard drives installed, so the optical drive needs to be put back in and only the SSD should be installed when you're installing Windows for the first time.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

The easier way is just disconnect the HD SATA cable from the drive and leaving the SSD in the optical bay.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Yea, I figured that out after I swapped the hard drives. Oh well, it's working now so that's all that matters.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:02crwdne2893776:0

crwdns2892346:0crwdne2892346:0

What SSD are you using? That version of bootcamp may not see the new drive. What macOS are you running?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

I am using a Samsung 860 evo SSD and macOS Mojave 10.14.3. When I get to the Windows installer, the bootcamp partition is there but, when I select it the error message mentioned above pops up.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I couldn't get back to Sierra but, I dont know if Mojave is the problem, I can still run bootcamp and install windows on the original hard drive. Just not the solid state drive. It still wants me to change something in bios to make it bootable.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I think I see the confusion here! You need to run BootCampo from the boot drive it can't run on the secondary drive!Thats why you're encountering issues.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Matt crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 3

crwdns2894768:07crwdne2894768:0 10

crwdns2894768:030crwdne2894768:0 60

crwdns2894770:0crwdne2894770:0 4,313