crwdns2894164:0crwdne2894164:0

MacBook will not charge.

I have tried a new charger, but it’s the same. Sometimes I get a solid Orange light, sometimes green. It stays on 0 percent, and doesn’t move.

When I look at the battery statistics it says that the capacity is 5246 and 627 cycles.

Any ideas?

Update (12/19/2018)

Block Image

The light is now green but still no charge. Its solid green.

UPDATE (07/19)

Sorry to resurect this but I’ve only just got around to a new I/O Board attempt.

Was strange as before it was always on 0 - 1 percent and not charging, replaced the I/O board and now its on 20 odd percent, still not charging, and battery is being used but going down.

Block Image

Any other ideas as I’ve tried a new I/O Board and 2 new batteries now.

Thanks!

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

Lets take a deep look here run this gem of an app CoconutBattery take a snapshot of the main window with the MagSafe charger connected and a second snapshot with it removed. Paste them here for us to see Adding images to an existing question

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

try a different dc in board

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

What’s that involve, is it doable myself?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

the i/o board guide that trevor posted

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Did you have a liquid spill at some point? I'm thinking the charging logic within the logic board is damaged.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:06crwdne2893776:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

andy hawkins crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 130