The smaller of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

crwdns2886949:0136crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Firmware Issue preventing any OS from being installed

This is a continuation from my previous question: SSD Upgrade on Mid 2013 MacBook Air Not Working

The original Apple SSD is toast. So we need a replacement; no idea what OS it was running beforehand.

Have tried a replacement NVME drive and adapter with a USB High Sierra installer but the installer would always fail and restart.

(As stated in previous question)

I have now bought an NVME drive and adapter with High Sierra preinstalled, but it cannot boot into it.

I have tried booting into into internet recovery mode, but it refuses to accept my wifi password. Ironically, I was able to get into recovery mode a few days prior, but that was when I only had the NVME plus adapter plugged in and nothing was shown in disk utility.

I have now plugged an external drive into the other USB port and installed the original OS Mavericks from a USB installer (it may have been mountain lion, but that shouldn’t matter) on the external drive.

While in Mavericks on the external, I tried connecting to the internet, every time it says connection timed out when verifying password. I connected to a different slower network finally. I tried updating it to High Sierra, and got an error message about a firmware problem.

I then read online about firmware problems, and it said I need the OEM SSD inside it to perform the update. As the original one is toast, I took an Apple SSD out of my 2015 MacBook Air (should still work, this is a 2013) and tried installing Mavericks there.

The Apple SSD doesn’t even appear, I thought this was because it was still APFS, so I booted into the High Sierra installer and formatted the drive as Journaled and restarted. It STILL wouldn’t appear in Mavericks Disk Utility.

I am at a loss. I have already ran ASD and it found NO problems. Upon booting while holding the d key (with the toasted drive in it, and with the new name drive and adapter) it only says that something may be wrong with the storage device.

I know that all Mac’s undergo a necessary firmware update for the new APFS protocol when upgrading to High Sierra, but how can I possibly do it??

Block Image

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0



press cmd with space then type terminal to open terminal

Type sudo diskutil verifyDisk disk0

enter password if asked

Type sudo diskutil repairdisk disk0

type y to start disk repair

Install High Sierra!


crwdns2889612:0crwdne2889612:0 2


That's a good tip.

I booted into mavericks on the external drive and used this and it checked the firmware partition and said "all good". Trying to use this command on disk1 (the nvme drive) results in an error about improper formatting. As expected, as Only High Sierra can recognize NVME.

So I tried to install High Sierra within Mavericks but the external drive was still grayed out, stating it's still missing the firmware partition. :/ It literally checked and said it was there...

Do you think it was possible that this machine lost power mid firmware update? What could have possibly happened?


Check the date and time through terminal in the installation setup.

Use this guide on how to do it:

Usually this issue occurs when the battery was unplugged / flat before as that resets date and time to 01/01/1980.



I partitioned using AFPS and it let it install on the usb stick. I tried using the other journaled one and it brought up the partition message firmware. Hope it helps.


crwdns2889612:0crwdne2889612:0 0

Had to install an Apple SSD and manually update to High Sierra. Then I could use the nvme drive and adapter.


crwdns2889612:0crwdne2889612:0 0


Jacob crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 4

crwdns2894768:07crwdne2894768:0 20

crwdns2894768:030crwdne2894768:0 83

crwdns2894770:0crwdne2894770:0 4,886