Computer won't start after changed battery, but did start once.

Changed battery because original was discharging too fast. New battery showed low capacity (according to onboard System Parameters software) and discharged rapidly. Replaced with another new battery, used only two screws to hold in battery and two on back cover, went through Battery Calibration process, System Parameters indicated all O.K. . Installed all remaining screws, attempted to use computer, wouldn't start up. No front light, no fan, no nothing. Removed screws to duplicate last known good conditions, no change. Tried disconnecting battery to start up with charging cord, no joy. Tried various re-setting schemes with onboard keyboard, no joy. Battery voltage at first 9-pin motherboard connector indicates 12.36 VDC. Randomly checked a few solder joints on motherboard, 12.36 VDC. (I don't know what/where any specific test points are.) Battery charger showed orange for awhile, now showing green light. Have tried "Power Cycling" and "Resetting SMC" with onboard keys; no joy. Suggestions?! Anyone?

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0



From right to left you got 3 pins grounded, then Smc 3.4v, no voltage, Smc 3,4v and then the three 12.5v charging pins. The two Smc pins should show 3,4v with some pulsing.

Since battery is not recognised to reset Smc you have to disconnect battery and keep the power on button pressed for at least 10seconds, you can exceed that to be on the safe side.

If after reset you have no charging and no pulsing on the 3,4v pins the Smc might have taken damage.

Otherwise it's likely something got damaged either on the charger IC or related components..troubleshooting at that level is not easy and in my opinion not worth a laboratory bill.

Update (04/30/2018)

Block Image

Thats a picture of the two power pads I was talking about..the two small squares to be shorted together..nothing else in that area, you can't miss or confuse them


crwdns2889612:0crwdne2889612:0 3


Thanks, arbaman! All is as you stated. Only thing wrong is that it still doesn't turn on! There was no charging apparent (green LED) on the installed battery, but that's because it's fully charged, I believe. Substituting another battery and using the charger, indicates that battery is being charged (orange LED). However, still no start with either battery or with charger attached. It almost seems as if the power button switch isn't working, but I don't know where those leads are, so can't check it...


@doug Good, better a topcase/keyboard than a logic board fault ;)

Right under the 4th keyboard pin you can see the two power pads, top one 3,4v and the bottom one grounded. Short them with anything metallic and see if it starts to get confirmation it's a keyboard fault.

Maybe try reseating the keyboard cable better if after cleaning it with might be in luck and it's just misaligned.


Oh, boy! Please excuse my ignorance. I have no clue about which pads you're referring. Can you direct me to a pic, or perhaps more extensive word description? I'm very reluctant to short pins together unless I know for _sure_ which are the correct ones!

BTW, thanks so much for your help!! Without schematics/wiring diagrams, this level of troubleshooting is nearly impossible!


@doug there you are, answer updated to include power pads picture


@arbaman, not sure if I got the right pads. When I shorted them, flames shot out...

Nah, not really!! You "da MAN"! Shorting those pads started the machine right up, and it proceeded as if it knew what it was doing. So, I shut it down with the menu normally, tried the start button, no joy. Started again by shorting, everything normal, shut down, start button failed to work second time. Does this mean a new keyboard, or is the start button itself replaceable?





Doug crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 2

crwdns2894768:07crwdne2894768:0 9

crwdns2894768:030crwdne2894768:0 42

crwdns2894770:0crwdne2894770:0 1,009