The Nintendo Switch is a handheld game console that can be played on the TV via a docking station, or on the go. Released March 3rd, 2017.

crwdns2886949:0494crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Device freezes after a few minutes of usage

Hello everyone.

In the hopes of getting a good deal online, I found a faulty Nintendo Switch that would not charge, so I thought I would be able to may be fix the problem. Allthough I have (probably) found the reason why the device does not charge (which is because of a crooked component I cannot identify next to the charging ic of the Switch (see here), I also noticed that even when there was enough power left, the device would freeze after a few minutes of usage, no matter whether I am doing something processing intensive or just waiting in the menu. It appears that the device is trying to check for something and then hangs up because it returns something wrong.

Perhaps anyone has further information regarding this issue?

I would certainly be happy to know.


Update (12/12/2017)

So I believe I managed to find more information about my problem.

Firstly, I have likely found what is causing the system to freeze after turning it on: It freezes when the power supply chip M92T36 is trying to read the current battery percentage. I know this because while the system is running and it hasn't crashed yet, the battery percentage stays the same. The percentage never seems to fall or rise actively. By the time the percentage should change, the system freezes, and I have to unplug the internal battery and then reconnect it to get the system to boot up again. After unplugging and restarting, the system shows the new battery percentage, but as I already mentioned, I can never see the power level actively drop, so it must be a problem with the power management IC.

Now that we understand the problem, I started to look for obvious hints of something being wrong with the charging chip. And by no surprise

Block Image

I found a missing component, marked in red, that I retrieved hanging around from somewhere across the board. If we look up the datasheet of the IC here on page 4-5, we can see that pin 2 of the chip labelled VSTR/ATST2 is responsible for "Analog TEST/ Debug Pin2", so I might assume that this pin os responsible for measuring the battery voltage and thus its charge.

Since the switch is reading an analog signal from this pin, and it does not receive any, the chip returns an unknown value to the switch and is system freezes because of that. At least this would be my suspicion.

Regardless, I have tried (and failed) putting the resistor back into place, as hot air does not make the thing seem to work, and I also tried bridgin the spot so that there again was a connection (even though without a resistor then). I am not sure if it is worth getting the resistor back in place, and if this is even the cause of the problem, especially because the chip looked like this when I first looked at it

Block Image

, so perhaps something else got bad?

All of this makes sense to me, but I am not quite sure how to attempt to solve or repair it, and ordering a completely new Power supply IC would take multiple weeks to arrive, just to find out that replacing the chip didnt help.

If just pcb shematics and wiring diagrams were available for the switch... Anyways, any help is still appreciated!

Update (13.12.2017)

Little update. I tried hooking up a potentiometer where the original resistor would be and tweaked it to different resistances, to see if the device would finally stop crashing after a while (like this)

Block Image

Unsurprisingly, that did not fix the problem. I did notice that, when listening very closely, the switch would make a high pitched noise, probably caused by some coils or chips, and when the device freezes, the sounds would stop. I am planning on running further experiments such as checking how much current is flowing when its running against when it froze, or if the freezing is caused by any overheating in certain parts of the mainboard. If all else fails I will try replacing the USB-C power management chip.

And as usual, let me know if anyone has a similar problem!

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 1


@tcrs_circuit may be able to ID that IC. (sounds like a game show.

welcome back to ID that IC!)


The Charging IC is actually a Rohm M92T36 USB Type-C power supply chip that is responsible for delivering and managing power. I made a few advances in my troubleshooting, see my newest post


Hi Daniel! I´m in a similar situation, got a cheap Switch that would charge and I am attempting to solve the problem. First I tought that the USB-C port could be the problem. I managed to get the system started with the new battery, but when i connect the psu in the charhing port it doesnt respond. It shows no signal of charging. When the charger is connected, the system strarts to overheat (even when it is off). I dont get the freezing issue, but the console turned off once, i presume as a protection due to overheating.

I also suspect the M92T36 or the BQ24193 could be the problem and i would like to identify the faulty component before ordering the part online.

Did you manage to make any progress with your repair?


I'm currently on the exact same situation. I'll try to reflow the board in an oven, and see if –somehow– it fixes the issue. The Switch is not charging, but the battery is working properly, since I've tested in another console. Hope it does help, or I'll have to buy a new M92T36 and try it, I've read somewhere else that changing it solves charging issues.





So I finally managed to fix the issue.

It was not a problem with any missing resistor at all. It turned out to be a bad solder connection on the Mainboard on any of the BGA chips. The troublemaker was most likely the CPU that had a cracked solder joint from the changing temperatures the device was used in by the previous owner, or just a manufacturing problem.

Anyways, reflowing the board in an oven at 200C or 369F for a couple of minutes seemed to have fixed the issue. No more freezing after a few minutes, and in fact the device was running for a couple of hours now without freezing.

So If anyone comes across a similar issue of where the device freezes after a while, try using popular DIY board reflowing methods using toaster ovens etc. found on the internet or consult a professional from a repair shop and let him reflow the CPU or DRAM for you. If best the whole board because I do not know for sure which chip actually had the issue, but again, it was most likely the CPU.

I will be closing this thread now. Thanks for any help!


crwdns2889612:0crwdne2889612:0 0


What about the no charging problem? How did you solved it?




Daniel crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 2

crwdns2894768:07crwdne2894768:0 9

crwdns2894768:030crwdne2894768:0 45

crwdns2894770:0crwdne2894770:0 6,249