Released October 2008 / 2.4, 2.53, 2.66, 2.8 or 2.93 GHz Core 2 Duo Processor

crwdns2886949:0374crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Charging and Other issues.

Hey, I am currently using a MacBook (NOT MacBookPro) from 2008. Recently, the battery puffed up, and the charging was getting funky before that, so I got a new battery. Now the new battery and charging cord I bought will not hold a charge. The mac tells me the battery is "not charging" even when it's plugged in, and that is the only way I can run it - if the cord is plugged in. If the cord comes out, the mac shuts off and will not start at all until the cord is replaced.

After some research, I found that this may be caused by settings in the SMC, or also by issues with firmware. So I tried resetting the SMC as per the instructions on the Apple site - that was useless. Nothing happened, plus, how can you reset anything at all with the battery removed from your computer, and the computer shut down? I am confused by this. But I did it. Nothing happened. I tried a slight variation of the process, suggested by my nerd friend, still nothing. So I moved on to trying to manually update the SMC firmware, since some of the updates seem to address this exact issue. All the updates would not start because my mac "doesn't need" it, or it would say they weren't compatible versions.

I guess my question is this - does anyone have any bright ideas on how to manually MANUALLY install the SMCUpdate? I know that my computer needs this, I don't care what the MacUpdate program says! The firmware is all jacked up, but my mac thinks it's up to date and functioning properly. I looked at the Console log, and noticed many, many instances of objects being released without pools. It says "no pool - just leaking" in the logs during the times where I was trying to install this SMCUpdate. ANY HELP??!? :D

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0



Might not need an SMC update. First go to the apple logo, about this mac and then to system profiler, an then to the power tab on the left side. Now make sure your battery is already pluged into the computer and check to see what it says. Does it say the battery condition is good? Does it say thats its plugged in and charging? Whats the cycle count? And also did you buy a decent quality battery or the cheapest piece of crap you could find? I had this issue on another computer where the battery was in, wouldnt charge, got it to charge once then wouldnt charge ever again.

Hope this helps and your answers could help me fix your issue!


crwdns2889612:0crwdne2889612:0 1


Charge Information:

Charge remaining (mAh): 0

Fully charged: No

Charging: No

Full charge capacity (mAh): 0

Health Information:

Cycle count: 464

Condition: Replace Now

Battery Installed: Yes

Amperage (mA): 67

Voltage (mV): 4460

It is giving me partial info from the old battery that almost exploded. The one I replaced. The charging cycles are how many were on the old battery, and it also said "Replace Now" for old one. Seems like it's stuck or something. It recognizes the power supply, but it will not charge the battery with it. Like it's there, but not there.


Have you tried resetting NVRAM or SMC? You can do that by holding command + option + P + R keys together at boot. stop holding once it restarts with a chime again (at least 2 chimes should be heard.)


Also, the new battery is the standard issue Mac battery, not a knockoff.


Aiden Backer. Did you even read the post? It says for like 70% of it how the smc couldnt be reset and whatnot


I gave it a shot anyway, the NVRAM is one thing I didn't try before. It did the chimes thing like it should, and when it started the battery icon said "no batteries available". That's new. So I rebooted again with the same process. It went back to "not charging" now. I thought maybe my charging port/connection is damaged, but then the green light wouldn't be on and the cord wouldn't be the only thing keeping my computer powered right now, right? If it were damaged, wouldn't the computer not respond to it at all? ARRRRG. I am very stumped here, and not many places near me dowork on older macs.




Two things to check.

If your battery was puffed up, it could well have surged and blown the fuse on the mlb.

Check the mlb battery connections for verdigris.


crwdns2889612:0crwdne2889612:0 0


Sarah Huber crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 291