crwdns2894164:0crwdne2894164:0

Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus. Identifiable by the model numbers A1549, A1586, and A1589.

crwdns2886949:05080crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Even after replacing home button, its still unresponsive sometimes

I started having problems with my home button the other day. It only worked about 10% of the time, and didn't work at all for long presses. Touch ID also stopped working.

So I thought that I would go and replace the home button.

Ive now replaced the home button and it is still having the exact same issue.

It still only works 10% of the time.

I am now starting to believe that the problem isn't the home button, but somewhere the home button connects to. I don't want to have to replace the WHOLE front of the phone just to fix the home button...

Any suggestions?

This is a very strange issue.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Will my next best bet be to replace the LCD shield since it contains the home button flat cable?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Yeah. Anything more would be a logic board issue.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

iPhone 6's home button has nothing to do with the screen. It's completely separate, the cable too I believe.

What exactly did you replace? The button? Or the daughter-board beneath the button? https://d3nevzfk7ii3be.cloudfront.net/ig...

If the button still works, but only "10%" of the time, sounds like it's simply dirty where the connection bridges.

If you can get to the mechanical switch (the clicky thing where the home button presses) when you take your phone apart, put a couple drops of isopropyl on to it (no less than 90%, 100% is best) and click it rapidly around 50 times.

Add another drop, click again. Then reassemble the phone.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Yeah I figured that, but I found out you can get the LCD shied which has the home button cable running along it to the top of the phone by itself, so I was planning on replacing that next as that may be the thing broken?

I replaced the whole piece that you have pictured.

I have tried isopropyl around the button, but that did nothing.

You suggest that I apply the isopropyl to the actual clicking part? (which is the bit in the centre of the back of the button) ? I don't know how that would help as the actual mechanism seems to be inside that metal shielding?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

calebmanley1996 crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 0

crwdns2894770:0crwdne2894770:0 58