R3 button does not work even after replacing the stick entirely

For quite a long time now, I have been unable to use special weapons like the Inkzooka in Splatoon because my R3 button is unresponsive. I have a fair bit of experience fixing hardware stuffs in consoles so I've made my own efforts to attempt repairs over the past few months. I started by calibrating the analog sticks to a neutral position but saw no improvement. Then a friend let me borrow her Gamepad to see if I could narrow down a particular piece of hardware that I could get off eBay. First I used her Gamepad on my system, and it worked perfectly. Special weapons were activated normally. Then I got into dissecting the pad. I replaced the entire right analog stick, and the entire motherboard. Even this solved nothing. I gave up after that. When we swapped the motherboard out I kept all of my cables and wifi/nfc boards. I am baffled at this. Maybe I should try the little nfc and wifi chips too? I assume the pad communicates with the system via the wifi chip, but what are the chances it would refuse to send a single button's command?

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0