Reviving my MyPassport external hard drive


My external drive stopped working a few months ago. It would spin without making any sound in particular, but it wouldn't be recognized by any PC and OS. On Linux and on Windows, it does show up when I run the lsusb command on Linux or when I open the device manager on Windows, but it seems like it's not seen as a hardware. Today, I took it apart to see if there was something I could do about it. Unfortunately, it doesn't have SATA, but IDE connectors, and I'm not comfortable with these. I'm adding pictures, I hope this will help. I'm still able to connect the USB cable that came with it (I also tried another one) but is there anything else that I can try to be able to recover data at least.


UPDATE : It seems like there is no mouvement inside the hard drive. I just tried to plugin another 2.5" hard drive via USB, and I noticed a huge difference in terms of vibration and noise. The WD has almost no vibration at all, and it does a little buzz. So... Does it mean that the hard drive is dead?

Block Image

Block Image

Block Image

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0


That doesn't look like a regular IDE connection to me. Maybe someone else will know what kind of connection it is.


It is not an IDE connector. As far as I know, this connector is for diagnostics only.

These drives are SATA internally, but have the SATA-USB converter built in and can only be accessed through the USB port. I once converted a similar drive to SATA (it is now sitting inside my desktop machine as an internal SATA drive) because the USB interface had flaked out. However when you do this conversion you say goodbye to any data that's on the drive, because the USB interface appears to contain some sort of hardware encryption and the data will be scrambled even if you do not explicitly enable the encryption by setting a password on the drive.


This is Western Digitals way of making it harder to repair, upgrade, or recover data from external drives. They want you to buy a new one, or send it to them for data recovery and repair.


Thanks for your replies. I just updated the post. There seems to be no active inside the hard drive.





If it shows up in Microsoft Device Manager, Try this:

Fix a corrupted Driver...

- Right click on the drive in Device Manager and uninstall the drive ( also select "delete the driver software for this device")

- Shut down your PC completely and unplug the drive.

- Start up your computer, after your computer boots up, plug the drive back in.

  • What this does: It will download a fresh copy of the driver software.

If this does not work, The Hard Drive is bad internally, or the PCB board is bad. You can get a donor PCB for this drive, but you have to either swap the firmware chip yourself or send it in so they can replace the firmware chip to match your drive.

Here is a link to a company that does this...


crwdns2889612:0crwdne2889612:0 1


No luck with that, but I have updated about the issue. Please check my update on the original post.


Oh ok... Time for a new one. That drive by it's self as a donor is around $178.00


Actually storage space is not really an issue for me, but there are data on this drive that I would like to recover. It's not important files, but it was almost full and it would be a pain to have to redownload almost 500GB. I'll just keep this thread here hoping that somebody else will have a solution/suggestion someday.


If a mechanical drive fails, and you want to recover the data, You will have to send it to a data recovery company that has a lab where they 1. Either replace the control board " like I mentioned" or 2. they take the hard drive apart in a clean room. Then they put the platters that contain the information into another working hard drive chassis to enable recovery of the bad drive data. There is no other solution.


Sounds like a lot of work them. Thank you for all the explanation.





Andre crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 2

crwdns2894768:030crwdne2894768:0 12

crwdns2894770:0crwdne2894770:0 1,756