crwdns2894164:0crwdne2894164:0

Guides for kitchen appliance repair and disassembly. Kitchen appliances have long helped people fix dinner. Return the favor, and the fix your appliances when they break.

crwdns2886949:02624crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Light powers on, but water does not heat

Aroma AWK-125S Electric Kettle

A while ago myAroma electric kettle from target stopped working- if I flip the switch the light powers on, but it does not heat the water. I'm presuming the heating element has failed- does anyone know anything about taking apart kettles and obtaining/replacing the components? Also any other ideas of what it could be- like a blown fuse that would be an easy fix? I know nothing about these kettles so at a loss here.

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

Do you have it disassembled? Most likely a thermistor acting as a fuse. If you have it apart, post some images with your question.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

not yet... are there guides out there to electric kettle teardowns? haven't found any, all forums are just saying chuck it, but &&^& that man... if nobody has anything in a day or so I'll take a crack at it and post pics

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I hear you on that. I am all for giving it a shot. I'll check local garage sales and Goodwill stores and see if I can come up with something.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I'll probably take a stab at this on tuesday when I have time. Will post updates ofc

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I have my kettle lit up but wont heat. I already dismantled the parts and see if there is any wiring connection or lost contact but it seems none.

Anybody has an experience or idea about this? Thank you!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2893776:03crwdne2893776:0

crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

crwdns2893810:0crwdne2893810:0

So I finally found time today to take it apart, and saw nothing immediately wrong with it- in true repair form, the kettle magically worked again after my taking it apart and putting it back together again. I'm guessing probably a faulty lead or something, don't know for certain, but at least I have tea.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

What tools did you need to take apart? Was it the base or the kettle with the problem?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

rab777hp crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 13

crwdns2894768:07crwdne2894768:0 96

crwdns2894768:030crwdne2894768:0 500

crwdns2894770:0crwdne2894770:0 58,898