crwdns2894164:0crwdne2894164:0

When I plug the urn into an outlet nothing happens?

When I plug my faberware coffee Millenium FSU236 urn into an outlet, the device won't work. What might be wrong with my device?

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

My wife bought Farberware coffee make 3days ago it plugin light come on but nothing.. Will not let you choose cup, ground, or k-cup..

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:03crwdne2886779:0

Peggy, a number of things could be wrong, so you should start with the simplest things (your statement that the "device won't work" implies no heating at all, which implies an "Open Circuit"):

1) Is the outlet working properly? Check it by plugging something else into that outlet (a lamp, for example) to test the outlet. If the outlet checks out OK, then....

2) Next, inspect and check the cord - if you don't know how to check the electric cord for continuity with an electrical tester, then simply replace the cord with a new one. If the new cord doesn't fix the problem, then......

3) The next steps would require disassembly of the unit to see why and where there is an "open circuit" somewhere inside the unit. It does not sound like you could tackle the disassembly and repair of the unit - some electrical knowledge and testing capability is required.

That is a very nice coffeemaker and is worth fixing. You have not provided much in the way of symptoms; just that the coffeemaker does not work. Does the urn heat up at all? Does the cord get warm?

Zenon

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

Im having the same problem. I’ve narrowed it down to the AC power cord. The urn itself is usually pretty durable. So unless you dropped it, or got the whole exterior wet, the unit itself should be fine. Heres a link for the percolator electrical Cord https://www.amazon.com/dp/B000QFDMQI/ref...

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

This is called an open circuit. A number of possibilities come to mind:

1) Bad cord (cheap fix)

2) Bad wall outlet (easy check - plug working lamp in and also try plugging coffeemaker into another outlet)

3) Circuit breaker has tripped (could be one-timer or an indicator of a more serious wiring or breaker problem). Circuit breaker normally controls multiple outlets, so check other outlets.

4) Next checking options involve disassembling coffeemaker bottom, looking for “open circuit” inside: loose connections, broken wiring, defective thermostat, defective heating element (not common), broken plug pins etc. Will need Multimeter and some expertise to do this checking (or someone who has this expertise).

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

peggy libby crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 10

crwdns2894768:030crwdne2894768:0 38

crwdns2894770:0crwdne2894770:0 2,602