crwdns2894164:0crwdne2894164:0

The Sony Xperia Z3 is an android smartphone released in 2014 known for it’s long battery life and durability.

crwdns2886949:0114crwdne2886949:0 crwdns2858137:0crwdne2858137:0

No Service at all

My Z3 says no service, my sim card works well at other phone,

and my contact in my sim card still can be viewed.

What have gone wrong, and what should I do?

Thank you

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 23

crwdns2893872:0crwdne2893872:0:

maybe you baseband version is missing,same like me

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

if i reinstall firmware might fix the problem??

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Why does my phone tells me no sim card and how can I work on it

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:010crwdne2886779:0

crwdns2893814:0crwdne2893814:0

Hi Tobias,

I got the same problem. I tried to update using PC companions but it didn't work, still the same old 5.0.2. Let's wait for the 5.1.1 update, hope will be sooner. By the way I'm from Canada.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

Hello, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Ok Folks...Its the antenna board located at the bottom of the phone. The part costs $9 on ebay. Just confirmed thats the problem. Once you replace that small logic board, it'll work fine. Guaranteed.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

is there a similar solution for the compact version (z3c --> d5803)?

any help is much appreciated!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Hello i have a sony Xperia D5316 and it's not connecting to any mobile networks at all, the sim works fine in other phones and it does recognize the sim by even downloading the correct carrier data settings but it doesn't connect to any of the carrier networks i tried, searching for a network in settings is never ending as it seems to can't find any during the search, i cant even change the data mode type eg: cdma, gsm only etc. could this be an antenna problem or could it be that the upgrade to lollipop affected it some how? Thanks in advance for your responses...

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

buenas-noches-amigos-tengo-el-mismo-inconveniente-llevo-dos-meses-con-el-lo-lleve-donde-lo-compre-y-me-sacaron-diciendo-de-que-fue-culpa-de-la-pantalla-por-que-esta-dañada-pero-el-móvil-funciona-correctamente-en-todo-su-aspecto-normal-le-cambiaron-el-software-pero-igual-entonces-decidí-llevarlo-ala-sony-y-por-el-momento-me-lo-tienen-me-llamaron-y-me-dijeron-que-en-esta-semana-me-dicen-cual-es-el-inconveniente-por-el-momento-me-dieron-tres-respuestas-las-cuales-pueden-ser-la-causa-la-primera-es-que-el-teléfono-este-desconectado-la-antena-por-eso-no-percibe-las-ondas.

la-segunda-de-que-el-teléfono-entro-ilegal-al-país-y-fue-bloqueado-y-la-tercera-problema-de-agua-o-húmeda-que-daño-la-antena-pero-descartan-la-ultima-por-que-los-sensores-de-humedad-están-respondiendo-de-que-el-equipo-no-le-ha-entrado-agua-soy-de-Colombia-apenas-me-den-el-dictamen-de-la-causa-se-los-estaré-sabiendo-muchas-gracias-por-el-momento-de-tomarse-el-tiempo-de-leer-mi-opinion

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

gracias mi amigo

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Usas demasiado "-"!!!!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Hi team, well i got the same problem on my experia z3 , No Service even the phone read the sim card, i also thought it was a software problem, unfortunately its not, its a hardware, its all about a green small mother board that control the phone network, here is a link for this peace (http://www.ebay.com/itm/Sony-Xperia-Z3-D...), after replacing it, every thing went great :) good luck, Alaa Eddine, Algeria

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

I'd call that a daughter board but anyway that connects to the cellular antenna on your phone. If that isn't mounted properly with the housing to hold it you may have this issue. Otherwise probably damaged.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Just look at this link may help you

http://www.thetruebox.com/sony-xperia-z3...

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

You Helped Me thank you

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Thank you, man this link was great and helpful

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Turn off lte, Go to settings, Mobile network, select wcdma prefered, search provider, and turn on lte, disable mobile network, and enable again

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

I just marked WCDMA prefered and it worked for me - I got my range back.

Done on Xperia XZ

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

https://www.youtube.com/watch?v=wP5W9c6A...

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

I know this thread is old, but I've recently run into the same issue and found a solution. In the settings, there is an option for "Reset Network Settings". This will remove all your wifi networks and any downloaded access point settings, but fixed the issue for me. Hope this helps any future solution seekers!

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Hi Sameer, I'm having same problem currently, not sure where to find 'reset network settings' option?

Gravely appreciated

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

If you open settings and search for "Reset", then it will be one of the options. It's actually in Settings > Backup and Restore > Reset Network Options (before the last option in the bottom)

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Block Image

Block Image

I struggled for 2 days to resolve this. And the solution was so simple. I resolved the issue accidentally.

Besides following all the recommendations (except the hardware part) on different online forums I was exhausted. Doing nothing, I started making a backup of my cell phone with an idle mind. And there I found an option to reset your network. I have Sony Xperia Z3 Dual. You should try this.

Go to Settings -> Back up and Reset

Scroll down

Go to "Network Settings Reset".

Then reset your cellular network. And bingo. It worked for me. I was able to make calls and use my cellphone in normal mode.

Please let me know if it worked for you. I can guide you for some more tricks.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Ddnt work for me

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

also dont work for me

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

just get a coper wayer and solder 3 micro pot antena all model solve work 100000000% im very sure like my fone

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

My sim card works I tried resetting my phone and turned airplane mode on and off and the service still isn't working. Can you tell me how to fix it please

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Ok Folks...Its the antenna board located at the bottom of the phone. The part costs $9 on ebay. Just confirmed thats the problem. Once you replace that small logic board, it'll work fine. Guaranteed.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Tobias crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 11

crwdns2894768:030crwdne2894768:0 45

crwdns2894770:0crwdne2894770:0 58,660