2.5 GHz dual-core Intel Core i5 processor (Turbo Boost up to 3.1 GHz) with 3 MB shared L3 cache.

crwdns2886949:0252crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Battery not charging after minor water damage


My wife spilled the smallest amount of tea on her a1425 Macbook Pro Retina from late 2012. After letting it dry she tried to see if the laptop was still working. At first it looked promising because the system started up normally and everything was running without any noticeable difference until she tried to run in from the battery.

As soon as the MagSafe was disconnected the unit shut off immediately. After plugging back in she noticed that the battery status says replace now and that the battery is not charging. The LED on the MagSafe starts out green and then turns amber and stays amber while connected.

We tried to thoroughly clean the internals with isopropanol multiple times but it made no difference. I also tried replacing the DC input board, tried a different (new) MagSafe adapter, and tried a new logic board (820-3642).

Nothing seemed to make any difference. I would hate to have to replace the batteries because they only have a cycle count of ~220, but is it possible that the batteries are the cause of the problem or is there a fuse or resistor that could be the culprit? If you have any any additional questions please let me know.

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 2



Steve, "replacing the DC input board, tried a different (new) MagSafe adapter, and tried a new logic board (820-3642)." the only thing left is the battery


crwdns2889612:0crwdne2889612:0 2


Steve crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 1

crwdns2894768:030crwdne2894768:0 3

crwdns2894770:0crwdne2894770:0 556