crwdns2894164:0crwdne2894164:0

The PlayStation Vita is the successor to the PSP. It contains a beefed up processor and graphics, and includes the addition of a second analog stick. It was released February 15, 2012.

crwdns2886949:0152crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Why is my screen constantly just flickering

When I switch my psvita on and slide it down on the start screen all it does is flicker it like the home button is being pressed continuously. Every time I hold down the home button it stops flickering if I let to of the home button it carrys on flickering please can some one anwser back and also the power button dosenT work at all

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 3

crwdns2893872:0crwdne2893872:0:

I have thus same issue PLZ HELP ITS ANNOYING

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Hi did anyone find a solution to this?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

When you say home button, I'm guessing you mean the ps button? Not the action button?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

That is correct yes, the screen flickers on HOME SCREEN all the time, as if the ps button is pressed continuously. I did take it apart and can confirm that the ps button is not stuck nor touches the pc board.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Since you can open it and have had issues in that area. Chances are one of the PCBs in that area is damaged. Take a good long look at the circuits in that area and see if anything is damaged, raised, burnt or disfigured in any way.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

I have the same issue on vita slim. After disassembly totally change the main board to another vita slim, and the problem do not occur in the same way.

Exemple:

1- in the original vita slim with this problem, it only shows when some application uses GPU, like a game or a app using FTP (Vitashell).

2- After change the main board to 2nd vita slim, game plays well for some time, like 2 or 3 minutes and after that it hangs and show error saying it will "....shutdown [******]"

3- Replace back all pieces to vitas, reinstall firmware via safemode (on the problematic one), but after install fresh new firmware issue continues.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Victor James crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 1

crwdns2894768:07crwdne2894768:0 7

crwdns2894768:030crwdne2894768:0 27

crwdns2894770:0crwdne2894770:0 2,141