crwdns2894164:0crwdne2894164:0

7.9 inch display / Model A1432 / Available in black or white / Announced October 23rd, 2012 / 16, 32, or 64 GB capacity

crwdns2886949:0220crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Top of digitizer unresponsive iPad mini 1st Gen

Hi, I've had a search for people describing similar problems but no solution found for this one.

I have replaced the digitiser on an iPad mini 1st Gen following the iFixit guide closely, however approximately the top 5th of the screen is unresponsive to touch, below this the touch screen functions fine.

I have had a look at the digitizer socket which has no missing pins, also cleaned these incase there was some dirt obstructing the connection however the same problem occurred.

I have tried 2 different digitizers which have exactly the same problem. Have ordered a 3rd from a different supplier to see if it is a problem with the digitizer.

Would really appreciate any advice on this one, anyone had a similar issue?

Best regards,

Joe

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

Quick update: 3rd digitizer arrived from a different supplier and worked perfectly. I guess its down to dodgey 3rd party components.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:03crwdne2886779:0

And does touch not work in the same area on each screen?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

Yep exactly the same area doesn't respond, it's like a horizontal strip across the top 5th of the digitiser. Testing 2 different digitisers makes me worry it is something to do with the connection rather than the digitizer but I have inspected the connections closely and there are no damaged/missing pins. Is there anything else it could be?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

I agree I would say the digitzers are fine it's the iPad that is causing the problems

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Joe crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 1

crwdns2894770:0crwdne2894770:0 202