crwdns2894164:0crwdne2894164:0

Released October 24, 2011 / 2.2, 2.4, or 2.5 GHz Quad-core Intel Core i7 Processor

crwdns2886949:0390crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Location of Sound Card on Logic Board?

Hello All!

Currently the MacBook Pro I am working on, has no sound. When it reboots, there is no start up chime and while in operation there are no audio devices detected. This leads me to believe there is a hardware issue with the sound card. I am curious to know where on the logic board the sound card is located. If possible a picture would be extremely helpful!

Thanks in advance.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 2

crwdns2893872:0crwdne2893872:0:

Have you had any success? I've been having the exact same issue and since I'm not that qualified to be messing around with the logic board I was looking into it.

Thanks in advanced!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2886779:02crwdne2886779:0

crwdns2893814:0crwdne2893814:0

Hey thanks for the response.

So I think I may have found my issue, it seems that it may be unfixable but I am not 100%

Anyway in reviewing the logic board I see that I am missing something, the part is labeled ZJS7 and it sits just to the left of the cirrus audio chip. I have attached an image with the circled part I am missing.

Block Image

So it obviously broke off somehow, my question is, is it fixable?? Or is the only solution a new logic board?

Thanks in advance!

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

Anybody returning to this post from the future please note Z-JS7 is a Vishay 47u 6.3v tantalum capacitor and replacement is easily done by anyone with a hot air workstation.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Henninma, first try to look into the system information to make sure the audio hardware is properly detected and listed. If they're there, the sound chip is working. If the chip is not detected, do a SMC reset and see if it works.

In the audio config, check the sounds are output by speakers rather than headphones or optical output. also look into the headphone jack and see if there is some red laser. The output is probably stuck on headphone or optical output. Clean the connector to resolve the issue.

The sound chip is the cirrus chip above the battery indicator connector.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

henninma crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 3

crwdns2894768:030crwdne2894768:0 13

crwdns2894770:0crwdne2894770:0 3,191