crwdns2894164:0crwdne2894164:0

Won't boot to pretty much anything

I have a 2010 MacBook Pro that worked perfectly fine, until today where it decided to randomly shut off and restart. It would get about 3/4 of the way in the progress bar, restart, and the cycle repeats itself - until you force the computer to shut down.

Obviously I tried other methods of getting it to boot or even to allow me to reinstall the OS. Safe Mode - froze. Recovery mode - froze. Internet recovery - froze (somehow). Holding down the D key (for diagnostics) takes me to the internet recovery globe and not long after gives me -3403D. Even a bootable USB drive with the OS installer on it - froze. Startup manager and single-user mode still works.

Considering it also froze on Internet recovery and the bootable drive, it’s not a problem with my drive. Especially since the fsck command I tried on single-user mode mentioned the drive was fine.

Does anyone know what’s causing this and, if possible, how to fix it? Thanks.

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

crwdns2893810:0crwdne2893810:0

I literally just reseated the RAM, mashed the caps lock key (as if that would help) and all of a sudden it works fine.

…Perhaps try that?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

amatsuda crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 4

crwdns2894770:0crwdne2894770:0 22