Dualshock 4 won't turn on

Hello, I'm having a problem with my ps4 controller and I am not able to solve it, I'll explain here what happened:

One day at lunchtime I went to the living room and the ps4 was on and I turn it off, I thought the controller had turned ON during the night as it was on the screen when the ps4 is turned on, the next day the same thing happened but I wasn't to be able to turn off the ps4 or better I was not able to turn on the controller, so I thought it was normal since as it was connected to ps4, I thought the control was clicking the ps button all night so there was no battery, I started charging it for some time and eventually I ended up being able to connect the controller, I went to delete users because I was going to delete one and then I ended the session to go to another user normally when the control is not connected to any user it turns off if it was disconnected so it was normal but I went to connect it again and it was not turning ON anymore so I thought it was better for charging it for a while, I came back and managed to connect but I saw as soon as I turned off the control it didn’t turn on anymore, I did a lot of resets but it continued the same with both cable via bluethoot it didn’t turn on but I put the ps4 in safe mode to see if the cable worked, I went in this mode and appeared to connect with cable (normal) after connected the control still didn’t turn on but the message to turn on the cable control disappeared, I had already opened the control once a few months ago to fix those normal problems of the triggers not working correctly in shooting / race games and also to fix the analog problem in some games do the character move forward, I had already solved all this and put the control as new, I repeat this was still in 2019, so as I already had experience in fixing controls I went to open it to see if I found another problem and try to fix the control, I opened it all until I got to the front buttons, then I remounted everything thinking that either the flat cable that is connected to the board to the part where the charging port is or take the battery out and through it again, so I set it up and went to test it and it was turning ON, then I turned off the controller, I turned ON again to see if it worked and it was working, I closed it with the screws that I hadn’t done yet and went to ps4 NOW I wasn’t connecting again I tried to reset again and nothing...

appointments:

I left the controller to charge for an entire night, when i woke up a while ago i was doing something sitting in front of the controller and i heard the ps4 turning ON i looked at the controller and there was a light that i hadn’t seen yet blue but it wasn’t the normal blue light, i think it was the light blue button ps + share but it was not flashing after a few seconds the controller turned off.

I connected the controller to my phone via bluethoot and managed to connect it to my phone (by clicking on the ps + SHARE buttons, to activate the bluethoot) but after +/- 10 seconds of connecting and checking that the buttons worked, the control turned off automatically.

I don't see much to do to fix it, it's my third controller, I don't want to continue to buy controls that are worth nothing for 60 €, I hope that the ps5 controls don't have these problems, funny how my ps3 control has always worked until the end, "end" because I sold it otherwise it would still be good, since the ps4 ones I'm in the third ...

I would like to fix my control.

What I've tried:

Do several resets before and after,

Open the entire control and mount again,

Attempting to use the controller on the phone via bluetooth (it works for like 10 seconds then it turned off.

search a lot about this type of control error not turning on.

what I'm going to do:

mount another control of mine and see if it works on my ps4.


i remember seeing somewhere that could be due to a wifi error which i think is unlikely but i get a wifi connectivity error when i turn on ps4.

sry for my bad english

I really want to get my controller fixed, any help, thank you very much!

edit: the controller just turned on again but it turned off after a few seconds, i'm noticing that right now the controller is trying to turn on it is flashing light blue probably because i took the ps4 out of the plug to stop being turned on.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0