crwdns2894164:0crwdne2894164:0

The larger of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

crwdns2886949:0436crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Can't erase disk, nothing is working

I have a computer that I securely erased the SSD with Parted Magic.

I booted to the Mojave installer and went to diskutil to erase (reformat) the drive to prep for install. The SSD was not showing up.

So I went into the terminal and found the SSD via command “diskutil list”, it appeared at the bottom of the list as disk20, which I thought was weird because it is generally disk0.

I used terminal to erase the SSD for install: “diskutil eraseDisk JHFS+ Macintosh\ HD disk20”

The process got stuck on erasing at 50% and did this for a whole day.

I am very confused, at this point I’ve tried:

·         Using different bootable installer (high sierra, sierra, elcap)

·         SMC and PRAM resets

·         removing battery

·         using a different SSD (…so it is the computer not the drive)

·         And simply just trying multiple times

I am at a loss, any ideas guys?

Thanks in advance for the help!

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2886778:01crwdne2886778:0

Does Parted Magic format APFS? Why did you use it instead of Apples Disk Utility? Why the secure erase?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Parted magic formats the drive to NTFS, but I have never ran into this issue using Parted magic.

I always just reformat the drive back to APFS or JHFS.

The reason I use Parted Magic is because I work in a facility where data security is our number one priority.

We fix University machines and sell them to the public.

Apples disk utility doesn't actually securly erase SSD's.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

Since you're a Professional, I would invest (and I have) in all the different OWC Envoy external enclosures, so you can work with these Apple SSD blades. Try this one: OWC Envoy Pro Portable, Bus-Powered USB 3.0 Enclosure for Apple Flash SSDs, (OWCMAU3ENPRPCI) https://www.amazon.com/OWC-Portable-Bus-...

I get them cheaper because I order them with the upgrades.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

I do have something similar to this, for most of apples funky proprietary SSD's.

I usually have trouble booting parted magic on MacBook’s while trying to erase the drive in the machine, so I usually pull them, use the adapter, and wipe them in a PC.

I forgot to mention that I did this for both SSD's I tried in this machine.

Not really sure what the heck is going on here!

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Taylor Struna crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 1

crwdns2894768:030crwdne2894768:0 1

crwdns2894770:0crwdne2894770:0 84