crwdns2894164:0crwdne2894164:0

The Blendtec Total Blender is an all-in-one blender released in late 2004.

crwdns2886949:014crwdne2886949:0 crwdns2858137:0crwdne2858137:0

What's wrong with my Blendtec Blender?

My blender only runs for about 2-3 seconds. It's supposed to run for 2-3 mins. And it stops after 2 seconds and says "overload". Is it because of the speed sensor or the carbon brush?

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2886779:04crwdne2886779:0

probably temperature probe is gone. its like when you use hoover for too long... but its just my wild guess

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

mine started to do that a couple of days ago and now it's out completely, how do i get it repaired? through the manufacturer? thanks I WANT MY SMOOTHIE! :(

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

Hi, the problem is in the blenders rotor, it's shorted out. I can fix it for you if you have it.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0

crwdns2893872:0crwdne2893872:0:

Francisco Aguila, what a great idea. How about you fix one and make a guide from it. Post it on ifixit, so we can all learn how to fix our blenders.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Mine also says “overload” and there is smoke coming out of the rotor. Any ideas?

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Chuck crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 8

crwdns2894768:030crwdne2894768:0 24

crwdns2894770:0crwdne2894770:0 4,194