Why isn't the hard drive being detected correctly?

I have a Powerbook G4 Aluminum 12" 867 MHz. The original hard drive, a Toshiba MK4021GAS 40GB, started to have weird problems. It works intermittently, it will work for a few minutes, then not work, again and again. I know that it is definitely the drive as I have used the enclosure to get some data off it, with the same problems.

I bought a replacement hard drive, a Toshiba MK3021GAS 30GB. Now the powerbook doesn't detect it properly. On the tiger install cd, disk utility detects it as "POPHHB@ HK0001@AP" instead of "TOSHIBA MK3021GAS". The capacity is listed as 7GB, when it is supposed to be 30GB.

I have tried formatting the disk using an enclosure to HFS+. It didn't work. I have also tried to install os x on that hard drive via the enclosure, but the powerbook does not supply enough power through the usb port.

Any ideas on how to get it working again? I do not want to spend any more money on this computer than I already have.

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 -1

Where did you buy the HDD from? Have you checked with another computer?


Yes, I have checked the HDD with another computer. The seller also has a week guarantee.





The corrupted model name sounds almost like a bad cable. Can you get any other machines to recognize the drive correctly and format it (maybe using your external enclosure)?

Which hard drive did you test using the enclosure -- the 40GB or the 30GB one? You should test both with another computer to make sure it actually was the 40GB drive that was broken and not the cable or logic board.

To solve your power supply problem -- try to find (or make?) a USB cable that has 2 male plugs (to plug in to 2 USB slots), or buy/borrow a Firewire enclosure.


crwdns2889612:0crwdne2889612:0 1


I have tested both of the drives. Both are recognized correctly, the 40GB is just weird as usual. I'm going to try to get another computer to format it. I don't know which partition table type to choose though.


I succeeded in getting my powerbook to boot from usb, but the thing doesn't want to install to it.




azureskies crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 0

crwdns2894768:030crwdne2894768:0 1

crwdns2894770:0crwdne2894770:0 1,098