Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

crwdns2886949:01540crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Why won't this MacBook Pro boot after MLB swap?

So I have a customer's MacBook Pro in for liquid damage repair. She had spilled a VERY expensive cup of coffee on her machine and when I got it, at boot up it would beep three times, once every second, and repeat every 3-4 seconds. I diagnosed it as a bad logic board after cleaning out the obvious corrosion and experiencing the same issue when rebooting it. I sent the MLB out for repair and the repair shop was not able to fix it. So I ordered a replacement from iFixit.

It arrived yesterday and I decided to stay late last night and install it. I cleaned the old and then applied new thermal paste (bought from iFixit) based on the iFixit guide's method. It all went great, all her data looked fine, and everything I checked (camera, mic, wifi, etc) worked fine, so I left it on last night when I went home, to "burn it in" and make sure everything would work ok when she got it back.

This morning I came in and it was completely dead. Plugged in but dead. The light on the front was lit up, but it was "lights on, nobody home". I tried waking it up various ways, none worked, and I tried resetting the SMC, and then I tried just rebooting it and still got nothing; no fan noise, just absolutely nothing.

So I took it all apart again today and checked everything (which seemed silly because it was all just working, but I had to do the proper troubleshooting.) Everything checked out OK, connections-wise so I started on the track of a bad power button. It is possible that there was some liquid damage in the area where the power button lives, due to the nature of the spill and somehow it took the power circuit out last night. I haven't been able to pin down the point of failure yet so I am a little perplexed as to what the current problem is. I am pretty certain its NOT the logic board, because the system doesn't even try to power itself on to check the logic board. This leads me to believe it is the power button which has failed (probably due to built up corrosion) and I will next try changing the top case and see if that fixes it. I also tried jump starting it with the tips from

Am I heading down the right path here? Any other ideas or things I may have overlooked?

Thanks in advance for your advice!!!!


aka Mac Daddy

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 0


Check keyboard connector. Very likely culprit many times with not being plugged in all the way (sounds dumb but its worth mentioning). Also try a new DC jack. If neither of the above work its almost certain to be a keyboard issue. Many times during a liquid damage repair keyboards almost always have to be replaced as well. Please keep us updated!


crwdns2889612:0crwdne2889612:0 0


Mac Daddy crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 2

crwdns2894768:030crwdne2894768:0 2

crwdns2894770:0crwdne2894770:0 90