crwdns2894164:0crwdne2894164:0

Released October 2008 / 2.4, 2.53, 2.66, 2.8 or 2.93 GHz Core 2 Duo Processor

crwdns2886949:0491crwdne2886949:0 crwdns2858137:0crwdne2858137:0

WD MyPassport external hard drive won't mount to my MacBook Pro

When I plug my external hard drive into my MacBook it flashes its white light and begins to stay solid, but doesn't show up on my desktop. I opened up disk utility and it said it was not mounted. I tried to repair the disk, but I got an error: File system verify or repair failed. Is there anything I can do?

crwdns2893858:0crwdne2893858:0 crwdns2893862:0crwdne2893862:0

crwdns2894050:0crwdne2894050:0

crwdns2889612:0crwdne2889612:0 4
crwdns2892346:0crwdne2892346:0

crwdns2886779:04crwdne2886779:0

crwdns2893814:0crwdne2893814:0

Most of these drives can be changed to another external enclosure. I would get one that is self powered rather than USB pot powered.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 1

crwdns2893872:0crwdne2893872:0:

So I should get a self powered external, and then back up my external that I have now on the self powered one?

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

You can try that or just get an external enclosure, transfer the hard drive and see if it works. That failing, drop a new drive in the new and/or old enclosures.

crwdns2893770:0crwdnd2893770:0crwdne2893770:0

crwdns2892346:0crwdne2892346:0

Hi, i have the exact same problem on a wd my passport 2tb drive formatted in hfs + (for mac). The wierd thing is that it mounts on windows 7 via bootcamp and paragon hfs + for windows ... So i think the problem comes from os x (yosemite for me) and i dont wanna reinstall everything.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

I plugged the WD My Passport Ultra into my Window 8.* laptop and pulled up Windows Disk Management to ensure I had exFAT formatting and that the partition was ACTIVE. Corrected both, did a safe eject and plugged it back into the MacBook Pro and OSX 10.10 now mounts the drive. It works, try it.

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

use disk utility. erase the drive

crwdns2894046:0crwdne2894046:0

crwdns2889612:0crwdne2889612:0 0
crwdns2892346:0crwdne2892346:0

crwdns2893896:0crwdne2893896:0

Bryan Harris crwdns2893898:0crwdne2893898:0
crwdns2894754:0crwdne2894754:0:

crwdns2894766:024crwdne2894766:0 0

crwdns2894768:07crwdne2894768:0 1

crwdns2894768:030crwdne2894768:0 4

crwdns2894770:0crwdne2894770:0 6,907