Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

crwdns2886949:02170crwdne2886949:0 crwdns2858137:0crwdne2858137:0

Showing 100% battery but shuts off when unplugged?

Block Image

I have an iPhone 4s that has been water damaged. The only issue is that it will not use the battery at all. While plugged in it turns on and shows 100%, it immediately shuts off when unplugged. Everything else works.

I have disassembled the phone and cleaned all visible corrosion on the main board and flex connectors (there was very little corrosion near the power management unit, aka PMU).

I have checked all visible solder joints with a microscope and all components appear to be fine, with the exception of one capacitor near the PMU.

I have tried 3 different replacement batteries that were tested in other iPhones, the batteries are good, and charged to 4.0 Volts. I have also tried replacement charging ports, no change.

I have tested all of the small components near the battery connector with a multimeter and they are also fine. The battery terminal solder joints are fine.

When the battery is connected, the voltage across the board + and - terminals reads 0.0 Volts.

I need help finding which components/chips might need to be reballed or replaced to fix this issue. What IC's are related to this issue?

I have searched for hours for a schematic or PCB photo to show which IC is the culprit, and came up empty handed.

crwdns2893852:0crwdne2893852:0 crwdns2913956:0crwdne2913956:0 crwdns2893862:0crwdne2893862:0


crwdns2889612:0crwdne2889612:0 4


Give us more details on this "with the exception of one capacitor near the PMU." Post an image of this with your question. Follow this guide Adding images to an existing answer to add images.


my battery drained completely and it shows 100% when a charger is plugged and shuts down when charger is removed. i replaced the battery and it worked but is there any other way to reuse my old battery?


When I unplug my ipad2 after its charged to 100 percent the charge goes down without me uses it





Sounds like your logic board is at fault. I can guarantee you have a bad capacitor somewhere causing a short between the +/- at the battery connector.

you can check this with a multimeter by connecting the first and last pin of the battery connector. If it has continuity then you have a short. You will have to take out the emi shields and find out exactly which capacitor is causing the problem. sometimes you can take out the circuitry from a battery and solder it to a dc outlet and find where it gets hot. Most of the time you can tell visually where the short is due to the corrosion


crwdns2889612:0crwdne2889612:0 2


Thanks for the response, I have not attempted to correct the issue yet, I just did some further testing based on your suggestion. My results are as follows.

There is continuity between the + and - battery terminals on the main board with no battery and no peripherals attached, concluding that there is definitely a short somewhere.

When assembled, the phone only powers on when charging from a wall outlet. A USB port on a PC doesn't have enough juice. I wanted to backup the data before removing shields with a heat gun in case I toast the PMU, so I manufactured a custom cable, with +5V and GND being drawn from a wall adapter, and the two USB data lines connected to a PC. I get an Apple logo for 2 seconds, then black again, and it loops indefinitely, so a backup is impossible.

I am interested to know if this information can help you diagnose exactly which component could be shorted?


First of all do not use the heat gun to remove the heat shields. You will probably do more damage than good.

I usually pry the shields off the board CAREFULLY without damaging surrounding components.

You're looking for a damaged capacitor (brown with two lead ends) surrounded with corrosion. In some cases the lead ends are red brown or black!

Good luck. I hope you have the right tools or more damage will happen


Thanks for all the help guys, I really appreciate it. I do have some pretty good tools and I've been removing heat shields using a heat gun for over a year now, I use a taper on the heat gun to concentrate the heat to the posts of the shield and so far it has proven effective. This time, I took your advice and removed it without heat just to be safe.

When I made my cable I connected the red and black lines to a usb cable which was connected to a wall outlet, and I soldered the green and white wires to the USB cable which I connected to my computer for data transfer. I have done this in the past with HTC devices and it worked fine, but this iPhone just reboots indefinitely when I use this cable. Somehow the battery short is making the board not work properly with a USB data connection. Does this mean that my issue could be with an IC and not a shorted capacitor? The cap in the picture looks pretty bad on one end, I think I will carefully remove it and test for continuity again and post my results.



the battery is most likely bad. Same thing happened to me, took a battery from another 4s and that worked fine


crwdns2889612:0crwdne2889612:0 0

MY samsung note 3 faced the same problem. I was using my phone and had 75 % battery on it. I went out for sometime and when i turned on my phone it did not turn on. I was shocked, i thought i’ve drained it to 0%. I went and put it in charge then i power on once. It came and showed it had 100%. I took out the charge seeing it had 100%. but then it turned off. i tried power on but that didn’t work it , i tried this again and again. then i removed the battery kept it aside for 5 minutes put it back and then!! It turned on. it was back in the 75% battery.


crwdns2889612:0crwdne2889612:0 0


Dan crwdns2893898:0crwdne2893898:0

crwdns2894766:024crwdne2894766:0 3

crwdns2894768:07crwdne2894768:0 19

crwdns2894768:030crwdne2894768:0 98

crwdns2894770:0crwdne2894770:0 96,789