crwdns2894164:0crwdne2894164:0
crwdns2894186:0crwdne2894186:0

crwdns2893792:0crwdne2893792:0 Kyle ,

crwdns2892734:0crwdne2892734:0:

K45 Elite Won't Pull Water

crwdns2893800:0crwdne2893800:0:

Hi there,

We’ve had our K45 Elite for a number of years now and it’s always been great, however the last year or so, when it would draw water in from the reservoir, it did sound a bit weird, and prior to the issues I’ll get to, it started to sound a bit weak. But it still worked without fail for generally multiple uses daily.

However, one day, it brewed me about 2 oz of coffee instead of the 10 oz cup I had asked for. I tried to make another cup and it just…didn’t pull more water in (conveniently this was during the first week of work at my new job after having been laid off for 15 months). This is where the issues started and remain today. It basically won’t pull anything in at all. Occasionally I can get it to a point where it ''will'' draw water in (usually after a bunch of swearing at it and shaking it up and down while upside down over the sink), and then it’ll work just fine for a number of cycles before it gets to that point where it then doesn’t draw more water in and makes cups that are smaller and smaller, eventually down to about nothing.

Admittedly, I’ve never descaled the thing (nor has the light ever turned on), though I’ve always used filtered water. I’ve tried all the troubleshooting things I’ve seen - manually “pumping” the lines by rapidly moving the tank up and down with and without holding the vent tube up top shut, taking the feed line off the top and making sure the check valve works, making sure the needle holes are clear, etc. When I did get it to work one of the few times, I ran a descaler solution through it - and you can see crap in the lines right near the top of the pump, and a lot of it would come through into a cup, but in the end it always reverts back to refusing to pump when it needs more water.

I’m out of ideas as to where to go next - is this a control board issue, pump issue, something else all together?

Any help would be majorly appreciated, thanks!

crwdns2866306:0crwdne2866306:0:

Keurig Elite

crwdns2892198:0crwdne2892198:0:

open