crwdns2894164:0crwdne2894164:0
crwdns2894186:0crwdne2894186:0

crwdns2893794:0crwdne2893794:0 oldturkey03 crwdns2893798:0crwdne2893798:0 ,

crwdns2892734:0crwdne2892734:0:

Kitchenaid Speed 2 too fast, can't adjust it

crwdns2893800:0crwdne2893800:0:

Hello everybody!

I bought an KSM150 which  was bought in the Unites States around 2005. For using it here in Germany I use a Converter from 230 V to 120 V which works perfectly.

My problem is, that speed 2 is nearly twice as fast as it should be, speed 2 , 6 and 8 are nearly the same and speed 10 is a lot faster. I tried to adjust it, what didn't work. So i bought a new phase control board and replaced the old one, sadly without an effect.

Do you think it's the speed control plate or could it also be the Mixer Motor Governor which causes the problem?

Thanks for your help,

Alex

crwdns2866306:0crwdne2866306:0:

KitchenAid KSM150PSER

crwdns2892198:0crwdne2892198:0:

open

crwdns2893804:0crwdne2893804:0:

+528901

crwdns2893796:0crwdne2893796:0 Alex nordhoff ,

crwdns2892734:0crwdne2892734:0:

-Speed 2 too fast, can't adjust it
+Kitchenaid Speed 2 too fast, can't adjust it

crwdns2893800:0crwdne2893800:0:

Hello everybody!

I bought an KSM150 which  was bought in the Unites States around 2005. For using it here in Germany I use a Converter from 230 V to 120 V which works perfectly.

My problem is, that speed 2 is nearly twice as fast as it should be, speed 2 , 6 and 8 are nearly the same and speed 10 is a lot faster. I tried to adjust it, what didn't work. So i bought a new phase control board and replaced the old one, sadly without an effect.

Do you think it's the speed control plate or could it also be the Mixer Motor Governor which causes the problem?

Thanks for your help,

Alex

crwdns2866306:0crwdne2866306:0:

KitchenAid KSM150PSER

crwdns2892198:0crwdne2892198:0:

open

crwdns2893792:0crwdne2893792:0 Alex nordhoff ,

crwdns2892734:0crwdne2892734:0:

Speed 2 too fast, can't adjust it

crwdns2893800:0crwdne2893800:0:

Hello everybody!

I bought an KSM150 which  was bought in the Unites States around 2005. For using it here in Germany I use a Converter from 230 V to 120 V which works perfectly.

My problem is, that speed 2 is nearly twice as fast as it should be, speed 2 , 6 and 8 are nearly the same and speed 10 is a lot faster. I tried to adjust it, what didn't work. So i bought a new phase control board and replaced the old one, sadly without an effect.

Do you think it's the speed control plate or could it also be the Mixer Motor Governor which causes the problem?

Thanks for your help,

Alex

crwdns2866306:0crwdne2866306:0:

KitchenAid KSM150PSER

crwdns2892198:0crwdne2892198:0:

open